aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-20 21:48:42 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-20 21:49:29 -0700
commit2f26e8af669a8f27723f8b0f4820bd2b4ebd266a (patch)
tree157cd2a7fd2ad238e141a0d0d879434251c31ec4
parent1e6a27d8e226029689caa22a7cec10f8982ad180 (diff)
downloadmeta-openembedded-contrib-2f26e8af669a8f27723f8b0f4820bd2b4ebd266a.tar.gz
stress-ng: Fix build on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-test/stress-ng/stress-ng/0001-stress-ng-don-t-enable-TARGET_CLONES-for-musl.patch30
-rw-r--r--meta-oe/recipes-test/stress-ng/stress-ng_0.09.37.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng/0001-stress-ng-don-t-enable-TARGET_CLONES-for-musl.patch b/meta-oe/recipes-test/stress-ng/stress-ng/0001-stress-ng-don-t-enable-TARGET_CLONES-for-musl.patch
new file mode 100644
index 0000000000..cd9131df50
--- /dev/null
+++ b/meta-oe/recipes-test/stress-ng/stress-ng/0001-stress-ng-don-t-enable-TARGET_CLONES-for-musl.patch
@@ -0,0 +1,30 @@
+From 59f5ff72768f228cd530bb18a5fc3e8c4772857a Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 20 Aug 2018 21:43:14 -0700
+Subject: [PATCH] stress-ng: don't enable TARGET_CLONES for musl
+
+musl does not support gnu ifuncs
+
+Upstream-Status: Submitted [https://github.com/ColinIanKing/stress-ng/pull/27]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ stress-ng.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/stress-ng.h b/stress-ng.h
+index b9359a4..f228808 100644
+--- a/stress-ng.h
++++ b/stress-ng.h
+@@ -1090,7 +1090,7 @@ extern void pr_fail_dbg__(const args_t *args, const char *msg);
+ #endif
+
+ /* GCC5.0+ target_clones attribute */
+-#if defined(__GNUC__) && NEED_GNUC(5,5,0) && STRESS_X86 && \
++#if defined(__GNUC__) && defined(__GLIBC__) && NEED_GNUC(5,5,0) && STRESS_X86 && \
+ !defined(__gnu_hurd__) && !defined(__FreeBSD_Kernel__)
+ #define TARGET_CLONES __attribute__((target_clones("sse","sse2","ssse3", "sse4.1", "sse4a", "avx","avx2","default")))
+ #else
+--
+2.18.0
+
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng_0.09.37.bb b/meta-oe/recipes-test/stress-ng/stress-ng_0.09.37.bb
index 19ce641924..a6c327e38e 100644
--- a/meta-oe/recipes-test/stress-ng/stress-ng_0.09.37.bb
+++ b/meta-oe/recipes-test/stress-ng/stress-ng_0.09.37.bb
@@ -7,6 +7,7 @@ DEPENDS = "zlib libaio"
SRC_URI = "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
file://0001-Revert-Makefile-force-sync-after-build-in-case-reboo.patch \
+ file://0001-stress-ng-don-t-enable-TARGET_CLONES-for-musl.patch \
"
SRC_URI_append_libc-musl = " \
file://0001-Several-changes-to-fix-musl-build.patch \