aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2018-08-01 00:14:41 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-02 11:23:02 -0700
commitd561c5cb6bbcc0f44baaa65bc8878a121d4c9786 (patch)
tree9dbb238d15a360d517e0fe0616d7eb2efacccde8
parent19aeaf028f6819e5fa705593d4bcdbf0b98143e0 (diff)
downloadmeta-openembedded-contrib-d561c5cb6bbcc0f44baaa65bc8878a121d4c9786.tar.gz
vim, vim-tiny: Make vim provide xxd without vim-tiny doing it too
There is no xxd in vim-tiny, so there is no reason to provide vim-tiny-xxd. Besides, it is typically "xxd-native" that one wants to be able to depend on, not "vim-native-xxd" (then the old dependency on vim-native already did the trick). Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/vim/vim-tiny_8.1.0172.bb2
-rw-r--r--meta-oe/recipes-support/vim/vim_8.1.0172.bb4
2 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/vim/vim-tiny_8.1.0172.bb b/meta-oe/recipes-support/vim/vim-tiny_8.1.0172.bb
index 84ad659e06..23f6aec49a 100644
--- a/meta-oe/recipes-support/vim/vim-tiny_8.1.0172.bb
+++ b/meta-oe/recipes-support/vim/vim-tiny_8.1.0172.bb
@@ -2,6 +2,8 @@ require vim_${PV}.bb
SUMMARY += " (with tiny features)"
+PROVIDES_remove = "xxd"
+
PACKAGECONFIG += "tiny"
do_install() {
diff --git a/meta-oe/recipes-support/vim/vim_8.1.0172.bb b/meta-oe/recipes-support/vim/vim_8.1.0172.bb
index fd2afbc5ae..371fe35eec 100644
--- a/meta-oe/recipes-support/vim/vim_8.1.0172.bb
+++ b/meta-oe/recipes-support/vim/vim_8.1.0172.bb
@@ -1,5 +1,7 @@
SUMMARY = "Vi IMproved - enhanced vi editor"
SECTION = "console/utils"
+
+PROVIDES = "xxd"
DEPENDS = "ncurses gettext-native"
# vimdiff doesn't like busybox diff
RSUGGESTS_${PN} = "diffutils"
@@ -111,5 +113,3 @@ ALTERNATIVE_LINK_NAME[vim] = "${bindir}/vim"
ALTERNATIVE_PRIORITY = "100"
BBCLASSEXTEND = "native"
-
-PROVIDES += "${PN}-xxd"