aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-19 19:41:52 -0800
committerArmin Kuster <akuster808@gmail.com>2020-01-30 18:38:10 -0800
commitbb65c27a772723dfe2c15b5e1b27bcc1a1ed884c (patch)
tree2f13fc50fbe910eef53a43cb6e0a3d67e8a71183
parent9d6b30b3da3dcbfb573e3ce1f2a94720d014d997 (diff)
downloadmeta-openembedded-contrib-bb65c27a772723dfe2c15b5e1b27bcc1a1ed884c.tar.gz
fluentbit: Fix packaging in multilib env
Fixes ERROR: fluentbit-0.12.19-r0 do_package: QA Issue: fluentbit: Files/directories were installed but not shipped in any package: /usr/lib/libfluent-bit.so Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 99fe1dec83456100e0bc1c02581defa7aaf04a16) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch18
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit_0.12.19.bb1
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch
new file mode 100644
index 0000000000..8fe9f3e703
--- /dev/null
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit/cmake_multilib.patch
@@ -0,0 +1,18 @@
+Use CMAKE_INSTALL_LIBDIR instead of hardcoding lib path
+
+Helps build on platforms where libpaths are not lib/ but say lib64/
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -182,7 +182,7 @@ if(NOT FLB_WITHOUT_SHARED_LIB)
+ PROPERTIES OUTPUT_NAME fluent-bit)
+
+ # Library install routines
+- install(TARGETS fluent-bit-shared LIBRARY DESTINATION lib)
++ install(TARGETS fluent-bit-shared LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ endif()
+
+ # Static Library
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_0.12.19.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_0.12.19.bb
index e50aa71a9f..27b910b8be 100644
--- a/meta-oe/recipes-extended/fluentbit/fluentbit_0.12.19.bb
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit_0.12.19.bb
@@ -4,6 +4,7 @@ BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
SRC_URI = "http://fluentbit.io/releases/0.12/fluent-bit-${PV}.tar.gz \
file://jemalloc.patch \
+ file://cmake_multilib.patch \
"
SRC_URI[md5sum] = "7c8708312ac9122faacf9e2a4751eb34"
SRC_URI[sha256sum] = "23a81087edf0e2c6f2d49411c6a82308afc5224f67bbaa45729c057af62e9241"