aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Schwan <m.schwan@phytec.de>2019-10-09 14:32:18 +0200
committerKhem Raj <raj.khem@gmail.com>2019-10-09 23:27:15 -0700
commitaaeb37656349db7f8562bf0ac1c11685f20a5212 (patch)
tree2909f5840eae4decd79a94ce65141261bfbccaf2
parenta47d38561249411449cc62ba878eb7c36916fe55 (diff)
downloadmeta-openembedded-contrib-aaeb37656349db7f8562bf0ac1c11685f20a5212.tar.gz
python-waitress: Add recipes
Waitress is a pure-Python WSGI server. Signed-off-by: Martin Schwan <m.schwan@phytec.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-waitress.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-waitress_1.3.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-waitress_1.3.1.bb2
3 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-waitress.inc b/meta-python/recipes-devtools/python/python-waitress.inc
new file mode 100644
index 0000000000..732c31dbd7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-waitress.inc
@@ -0,0 +1,10 @@
+SUMMARY = "A WSGI server for Python"
+DESCRIPTION = "Waitress is meant to be a production-quality pure-Python WSGI \
+ server with very acceptable performance."
+HOMEPAGE = "https://github.com/Pylons/waitress"
+SECTION = "devel/python"
+LICENSE = "ZPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=78ccb3640dc841e1baecb3e27a6966b2"
+
+SRC_URI[md5sum] = "d9132d313de0c5e0fec34ef9ede5442e"
+SRC_URI[sha256sum] = "278e09d6849acc1365404bbf7d790d0423b159802e850c726e8cd0a126a2dac7"
diff --git a/meta-python/recipes-devtools/python/python-waitress_1.3.1.bb b/meta-python/recipes-devtools/python/python-waitress_1.3.1.bb
new file mode 100644
index 0000000000..26a628ea02
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-waitress_1.3.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools pypi
+require python-waitress.inc
diff --git a/meta-python/recipes-devtools/python/python3-waitress_1.3.1.bb b/meta-python/recipes-devtools/python/python3-waitress_1.3.1.bb
new file mode 100644
index 0000000000..83c8b66d82
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-waitress_1.3.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3 pypi
+require python-waitress.inc