aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2018-03-28 23:36:50 +0200
committerAndreas Oberritter <obi@opendreambox.org>2020-07-02 12:15:52 +0200
commit82914e377035e0d6a8e3e130cf9e43abc248f66b (patch)
tree5b1556c641b8e32a1ef74386d4adbd4b2354ea27
parente72e43a670b1f85a468395853a39ca3de3d95dbd (diff)
downloadmeta-openembedded-contrib-82914e377035e0d6a8e3e130cf9e43abc248f66b.tar.gz
autofs: install sysvinit script manually if systemd is enabled
Update-rc.d complains if no sysvinit script is present. This happens in hybrid systemd/sysvinit builds, because autofs does not install the init script if configured with '--with-systemd'. Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.1.5.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.1.5.bb b/meta-networking/recipes-daemons/autofs/autofs_5.1.5.bb
index f6f60fe0cf..03ed9ead3e 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.1.5.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.1.5.bb
@@ -78,6 +78,11 @@ do_install_append () {
if [ -d ${D}${localstatedir}/run ]; then
rmdir ${D}${localstatedir}/run
fi
+ # On hybrid systemd/sysvinit builds, we need to install the sysvinit script by hand.
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d -m 755 ${D}${INIT_D_DIR}
+ install -m 755 ${S}/samples/rc.autofs ${D}${INIT_D_DIR}/autofs
+ fi
}
SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"