aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2016-07-01 16:16:48 -0700
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:41 -0700
commit711c97a07925d67e48c37570daef7eec311cfd7f (patch)
tree9c95b2b1cf4f9255ad96f57d60c01a51481c0965
parent87e83981f4c6cb0c739510e34b0db3c3471db3e5 (diff)
downloadmeta-openembedded-contrib-711c97a07925d67e48c37570daef7eec311cfd7f.tar.gz
openconnect: PACKAGECONFIG certain dependencies
Some items now in DEPENDS are configuration options, so we create PACKAGECONFIG[] entries for them. We do not select pcsc-lite by default because it is GPLv3. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> (cherry picked from commit a27d4a75c503f8cab2188cfed78754d1a4157775) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/openconnect/openconnect_git.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/meta-networking/recipes-connectivity/openconnect/openconnect_git.bb b/meta-networking/recipes-connectivity/openconnect/openconnect_git.bb
index 6d3c252175..60e7e6e496 100644
--- a/meta-networking/recipes-connectivity/openconnect/openconnect_git.bb
+++ b/meta-networking/recipes-connectivity/openconnect/openconnect_git.bb
@@ -2,8 +2,17 @@ SUMMARY = "Open client for Cisco AnyConnect VPN"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=243b725d71bb5df4a1e5920b344b86ad"
-DEPENDS = "vpnc libxml2 gnutls lz4 krb5 libproxy pcsc-lite"
-RDEPENDS_${PN} = "vpnc"
+DEPENDS = "vpnc libxml2 krb5"
+
+PACKAGECONFIG ??= "gnutls lz4 libproxy"
+
+# config defaults
+PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls,"
+PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
+PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy,"
+
+# not config defaults
+PACKAGECONFIG[pcsc-lite] = "--with-libpcsclite,--without-libpcsclite,pcsc-lite,"
PV = "7.06"