aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge McCollister <george.mccollister@gmail.com>2016-05-27 15:56:35 -0500
committerAndreas Oberritter <obi@opendreambox.org>2017-02-16 11:29:16 +0100
commit31fa8a435311e28bfa51d30981c552e63d7d678a (patch)
tree1c0f0060d8b101d438137fa81f2764eb65672dbf
parent5a227a7d933ce9659a2dd6a746ab237c3797b700 (diff)
downloadmeta-openembedded-contrib-31fa8a435311e28bfa51d30981c552e63d7d678a.tar.gz
python-simplejson: change to setuptools
Change from distutils to setuptools. simplejson's setup.py is written to import setup, Extension, Command from setuptools and fallback to distutils if the import fails. Prior to this change files were being installed to a host polluted path /usr/lib/python2.7/site-packages/simplejson-3.8.2-py2.7-linux-x86_64.egg (even on ARM targets). python was unable to import simplejson. Switching to setuptools corrects the problem. Signed-off-by: George McCollister <george.mccollister@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit c2c895ec5496ab5813d20a4d011ecdc73e46b256) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta-oe/recipes-devtools/python/python-simplejson_3.8.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/python/python-simplejson_3.8.2.bb b/meta-oe/recipes-devtools/python/python-simplejson_3.8.2.bb
index a2a6c400f7..0c9112e445 100644
--- a/meta-oe/recipes-devtools/python/python-simplejson_3.8.2.bb
+++ b/meta-oe/recipes-devtools/python/python-simplejson_3.8.2.bb
@@ -14,7 +14,7 @@ SRC_URI[sha256sum] = "d58439c548433adcda98e695be53e526ba940a4b9c44fb9a05d92cd495
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit distutils
+inherit setuptools
RDEPENDS_${PN} = "\
python-core \