aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:28 -0300
committerAndreas Oberritter <obi@opendreambox.org>2017-06-26 22:59:19 +0200
commit2d82d488585e10fc18e5b604f5d78580ec611e41 (patch)
treebce21b7c460e48a5a3e878bf5dd73d33a734f376
parent8f74b26545440405fc9185b4424e66e5c5c97e3e (diff)
downloadmeta-openembedded-contrib-2d82d488585e10fc18e5b604f5d78580ec611e41.tar.gz
python-pysocks, python3-pysocks: Add recipe for version 1.5.7
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit ed70cd5761cf531fb5d71b02e901c43ff2a1aed2) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta-python/recipes-devtools/python/python-pysocks.inc11
-rw-r--r--meta-python/recipes-devtools/python/python-pysocks_1.5.7.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pysocks_1.5.7.bb2
3 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pysocks.inc b/meta-python/recipes-devtools/python/python-pysocks.inc
new file mode 100644
index 0000000000..0697fd7156
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pysocks.inc
@@ -0,0 +1,11 @@
+DESCRIPTION = "A Python SOCKS client module"
+HOMEPAGE = "http://python-requests.org"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1d457bcffb9661b45f799d4efee72f16"
+
+SRC_URI[md5sum] = "68f4ad7a8d4fa725656ae3e9dd142d29"
+SRC_URI[sha256sum] = "e51c7694b10288e6fd9a28e15c0bcce9aca0327e7b32ebcd9af05fcd56f38b88"
+
+PYPI_PACKAGE = "PySocks"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pysocks_1.5.7.bb b/meta-python/recipes-devtools/python/python-pysocks_1.5.7.bb
new file mode 100644
index 0000000000..8a24e4c49a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pysocks_1.5.7.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-pysocks.inc
diff --git a/meta-python/recipes-devtools/python/python3-pysocks_1.5.7.bb b/meta-python/recipes-devtools/python/python3-pysocks_1.5.7.bb
new file mode 100644
index 0000000000..6b09355572
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pysocks_1.5.7.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-pysocks.inc