aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2017-09-05 14:36:13 -0500
committerMark Hatle <mark.hatle@windriver.com>2017-09-06 15:00:55 -0500
commiteb209fe22a312e4e4db4710c02e1c1ada7530ef6 (patch)
tree2c8179308abd4d375ed27d59288257e328dc0ba9
parenta12d27e1f2667288aadf349bd98fb0149785b6aa (diff)
downloadmeta-openembedded-contrib-eb209fe22a312e4e4db4710c02e1c1ada7530ef6.tar.gz
xorg-drivers: Add opengl distro flag requirement to ati and nouveau
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--meta-oe/recipes-graphics/xorg-driver/xf86-video-ati_7.8.0.bb3
-rw-r--r--meta-oe/recipes-graphics/xorg-driver/xf86-video-nouveau_1.0.15.bb4
2 files changed, 7 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-video-ati_7.8.0.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-video-ati_7.8.0.bb
index a1010087cd..d409a18630 100644
--- a/meta-oe/recipes-graphics/xorg-driver/xf86-video-ati_7.8.0.bb
+++ b/meta-oe/recipes-graphics/xorg-driver/xf86-video-ati_7.8.0.bb
@@ -9,6 +9,9 @@ DESCRIPTION = "Open-source X.org graphics driver for ATI Radeon graphics"
DEPENDS += "virtual/libx11 libxvmc drm xf86driproto glproto \
virtual/libgl xineramaproto libpciaccess"
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES += "opengl"
+
COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
SRC_URI[md5sum] = "f34d04a755e761e03b459155fa3ddcbb"
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-video-nouveau_1.0.15.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-video-nouveau_1.0.15.bb
index b10ee71154..2746821cd2 100644
--- a/meta-oe/recipes-graphics/xorg-driver/xf86-video-nouveau_1.0.15.bb
+++ b/meta-oe/recipes-graphics/xorg-driver/xf86-video-nouveau_1.0.15.bb
@@ -10,7 +10,11 @@ DEPENDS += "virtual/libx11 libxvmc drm xf86driproto glproto \
virtual/libgl xineramaproto libpciaccess"
RDEPENDS_${PN} += "xserver-xorg-module-exa"
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES += "opengl"
+
COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
SRC_URI[md5sum] = "717203cb87029cddcbccf7398f9ad8c3"
SRC_URI[sha256sum] = "aede10fd395610a328697adca3434fb14e9afbd79911d6c8545cfa2c0e541d4c"
+