aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2017-09-05 14:04:49 -0500
committerMark Hatle <mark.hatle@windriver.com>2017-09-06 15:00:55 -0500
commitc3fdfad9698749f26acb963f460a7599c78ad9f0 (patch)
tree6240f6dbc5763672d56dddeda88cc77aaa2e6533
parent675312667a667f9eb6b553f61d953056a99d050a (diff)
downloadmeta-openembedded-contrib-c3fdfad9698749f26acb963f460a7599c78ad9f0.tar.gz
glmark2: Set required distro features to opengl
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index d3766d916f..b72ced06ad 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -23,7 +23,9 @@ SRCREV = "ed20c633f1926d1dd78e3e89043c85a81302cbe6"
S = "${WORKDIR}/git"
-inherit waf pkgconfig
+inherit waf pkgconfig distro_features_check
+
+REQUIRED_DISTRO_FEATURES += "opengl"
PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11-gl x11-gles2', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gl wayland-gles2', '', d)} \