aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-08-30 17:16:29 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-02 08:45:48 +0200
commit907da2559bd7d1feb4fbb30b0ad7d7faebd62c0d (patch)
tree3af354e0beb763b402d4fad486ef2eeef4d69d94
parent2624ca3ea347eb3d6615eb20eca24c469cb57c75 (diff)
downloadmeta-openembedded-contrib-907da2559bd7d1feb4fbb30b0ad7d7faebd62c0d.tar.gz
librcf: link to libatomic
In commit 1d594f18f66700f0b2c03b7acf1104a825b155b4: [ librcf: Add -latomic to LDFLAGS ] I added '-latomic' to LDFLAGS, which worked for clang 3.9 but it does not work for clang 5.0, seems the linking order matters for clang 5.0, it should be after -lrcf. Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/librcf/librcf/0001-Add-CMake-build-files.patch2
-rw-r--r--meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb2
2 files changed, 1 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/librcf/librcf/0001-Add-CMake-build-files.patch b/meta-oe/recipes-devtools/librcf/librcf/0001-Add-CMake-build-files.patch
index cd0d1433f7..560c3a6d70 100644
--- a/meta-oe/recipes-devtools/librcf/librcf/0001-Add-CMake-build-files.patch
+++ b/meta-oe/recipes-devtools/librcf/librcf/0001-Add-CMake-build-files.patch
@@ -53,7 +53,7 @@ index 0000000..f6e24be
+####################################################################
+INCLUDE (${CMAKE_SOURCE_DIR}/VERSION.cmake)
+
-+SET (LIBRCF_LIBRARIES "-lpthread -ldl")
++SET (LIBRCF_LIBRARIES "-lpthread -ldl -latomic")
+INCLUDE_DIRECTORIES (${CMAKE_SOURCE_DIR}/include)
+
+IF (LIBRCF_USE_OPENSSL)
diff --git a/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb b/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
index 46b75c5142..43eff72a3d 100644
--- a/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
+++ b/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
@@ -23,8 +23,6 @@ SRC_URI[sha256sum] = "bbfcc88de502c39604878c395f516b03fff4eac63eb4f7f44c07d43383
S = "${WORKDIR}/RCF-${PV}"
-LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed"
-
inherit cmake dos2unix
PACKAGECONFIG ?= "zlib openssl sf-serialization boost-filesystem boost-asio protobuf json dll static shared demos"