aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei.gherzan@huawei.com>2021-03-05 16:02:53 +0000
committerKhem Raj <raj.khem@gmail.com>2021-03-05 14:54:37 -0800
commitb560210f74bd0fabe1938f8be31634d89709c735 (patch)
tree4005daf7b4f2a065f167d59ecccbc56cf9702ea6
parent759f66e10edb43483e1d254b2dedbac988cc4e8a (diff)
downloadmeta-openembedded-contrib-b560210f74bd0fabe1938f8be31634d89709c735.tar.gz
python3-aiohue: Integrate the hue control python module
Signed-off-by: Andrei Gherzan <andrei.gherzan@huawei.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohue_2.2.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiohue_2.2.0.bb b/meta-python/recipes-devtools/python/python3-aiohue_2.2.0.bb
new file mode 100644
index 0000000000..a2a7363f6c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiohue_2.2.0.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Asynchronous library to control Philips Hue"
+HOMEPAGE = "https://pypi.org/project/aiohue/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+# No license file available but the license is specified in PKG-INFO and setup.py.
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
+
+SRC_URI[sha256sum] = "35696d04d6eb0328b7031ea3c0a3cfe5d83dfcf62f920522e4767d165c6bc529"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-aiohttp"