aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClément Péron <peron.clem@gmail.com>2021-03-05 10:33:57 +0100
committerKhem Raj <raj.khem@gmail.com>2021-03-05 07:28:07 -0800
commit9232086c26a66ff77746beda5e7082ab39a930c4 (patch)
tree2e84ec1b636f98c86e58ef3466276c13d7155d44
parentd4ab3fd1ae2bfcabd238fbf22daa2513aebe39cc (diff)
downloadmeta-openembedded-contrib-9232086c26a66ff77746beda5e7082ab39a930c4.tar.gz
grpc: move grpc plugins to a new grpc-compiler package
Like it's done for protobuf and flatbuffers move the binaries produce by gRPC to a grpc-compiler package. This is more explicit and keep coherency with protobuf and flatbuffers. Signed-off-by: Clément Péron <peron.clem@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/grpc/grpc_1.36.1.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/grpc/grpc_1.36.1.bb b/meta-oe/recipes-devtools/grpc/grpc_1.36.1.bb
index 358ec80e87..eb137bef52 100644
--- a/meta-oe/recipes-devtools/grpc/grpc_1.36.1.bb
+++ b/meta-oe/recipes-devtools/grpc/grpc_1.36.1.bb
@@ -10,6 +10,11 @@ DEPENDS = "c-ares protobuf protobuf-native protobuf-c protobuf-c-native openssl
DEPENDS_append_class-target = " googletest grpc-native "
DEPENDS_append_class-nativesdk = " grpc-native "
+PACKAGE_BEFORE_PN = "${PN}-compiler"
+
+RDEPENDS_${PN}-compiler = "${PN}"
+RDEPENDS_${PN}-dev += "${PN}-compiler"
+
S = "${WORKDIR}/git"
SRCREV_grpc = "3b7f86e3516746c5f0db1947e0d65e94159bcb12"
BRANCH = "v1.36.x"
@@ -72,4 +77,4 @@ BBCLASSEXTEND = "native nativesdk"
SYSROOT_DIRS_BLACKLIST_append_class-target = " ${baselib}/cmake/grpc"
-FILES_${PN}-dev += "${bindir}"
+FILES_${PN}-compiler += "${bindir}"