aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2021-03-04 17:45:01 -0300
committerKhem Raj <raj.khem@gmail.com>2021-03-05 12:22:57 -0800
commit0758491737328adac70a06e9c03862452c7b1770 (patch)
tree3f74a5e0ca322f6832419cfb5f84ad7fe95a364e
parent69bbfe1a7d7713babf213947f029d3ca19683cbb (diff)
downloadmeta-openembedded-contrib-0758491737328adac70a06e9c03862452c7b1770.tar.gz
python3-requests: Support idna version 3.1
Change idna required version to use python3-idna recipe that currently is on version 3.1. Without this change python-request doesn't work as the idna version doesn't match the required versions. When bump python-request recipe, verify if the upstream project bumped the idna version and drop this patch. As this recipe was tested with python3-idna_3.1 don't allow higher versions. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch40
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.25.1.bb2
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch b/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch
new file mode 100644
index 0000000000..26332249da
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch
@@ -0,0 +1,40 @@
+From fc45beed40a86c8fc38fc430765c1c5d2c9961c2 Mon Sep 17 00:00:00 2001
+From: Fabio Berton <fabio.berton@ossystems.com.br>
+Date: Thu, 4 Mar 2021 09:26:48 -0300
+Subject: [PATCH] setup.py: Support idna version 3.1
+Organization: O.S. Systems Software LTDA.
+
+Change idna required version to use python3-idna recipe that currently
+is on version 3.1.
+
+Without this change python-request doesn't work as the idna version
+doesn't match the required versions. When bump python-request recipe,
+verify if the upstream project bumped the idna version and drop this
+patch.
+
+As this recipe was tested with python3-idna_3.1 don't allow higher
+versions.
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 7ba4b2a2..9d3b973e 100755
+--- a/setup.py
++++ b/setup.py
+@@ -43,7 +43,7 @@ packages = ['requests']
+
+ requires = [
+ 'chardet>=3.0.2,<5',
+- 'idna>=2.5,<3',
++ 'idna>=2.5,<3.2',
+ 'urllib3>=1.21.1,<1.27',
+ 'certifi>=2017.4.17'
+
+--
+2.30.1
+
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.25.1.bb b/meta-python/recipes-devtools/python/python3-requests_2.25.1.bb
index 6af836543b..cea8fd5178 100644
--- a/meta-python/recipes-devtools/python/python3-requests_2.25.1.bb
+++ b/meta-python/recipes-devtools/python/python3-requests_2.25.1.bb
@@ -3,6 +3,8 @@ HOMEPAGE = "http://python-requests.org"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+SRC_URI += "file://setup.py-Support-idna-version-3.1.patch"
+
SRC_URI[sha256sum] = "27973dd4a904a4f13b263a19c866c13b92a39ed1c964655f025f3f8d3d75b804"
inherit pypi setuptools3