aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEver ATILANO <ever.atilano@smile.fr>2023-03-24 15:42:21 +0100
committerKhem Raj <raj.khem@gmail.com>2023-04-05 15:57:09 -0700
commit74dcb3aa174a60a2343803d6b038a2a10113c926 (patch)
treef60ccef189c9cce2cfdc904a1445237495ee8484
parent7e4947d0b019f33e73cdb18ce0ac5662d7e2184e (diff)
downloadmeta-openembedded-contrib-74dcb3aa174a60a2343803d6b038a2a10113c926.tar.gz
meta-python: python3-lorem: Add ptest
Signed-off-by: Ever ATILANO <ever.atilano@smile.fr> Signed-off-by: Yoann Congal <yoann.congal@smile.fr> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-lorem/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-lorem_0.1.1.bb15
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lorem/run-ptest b/meta-python/recipes-devtools/python/python3-lorem/run-ptest
new file mode 100644
index 0000000000..8d2017d39c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-lorem/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-lorem_0.1.1.bb b/meta-python/recipes-devtools/python/python3-lorem_0.1.1.bb
index 9ce7a6293c..a855c39141 100644
--- a/meta-python/recipes-devtools/python/python3-lorem_0.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-lorem_0.1.1.bb
@@ -5,12 +5,25 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=5301c01b2bcdeedba23645f94db2f179"
SRC_URI[md5sum] = "e3f0064a94c13e19780eb724affdb426"
SRC_URI[sha256sum] = "785f4109a241fc2891e59705e85d065f6e6d3ed6ad91750a8cb54d4f3e59d934"
+SRC_URI += "\
+ file://run-ptest \
+"
+
PYPI_PACKAGE = "lorem"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
CLEANBROKEN = "1"
RDEPENDS:${PN} += " \
python3 \
"
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-unittest-automake-output \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}