aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-10-20 19:30:40 +0200
committerKhem Raj <raj.khem@gmail.com>2021-10-20 12:33:31 -0700
commitfc282987d2ea1695d53017397bb8771f3303c2ff (patch)
tree44a62243ddca0a6bda0f63fc81436a4205c870d7
parent2f9e843ef4c8e2dd59ce3f22f4f52e4ea41df3b9 (diff)
downloadmeta-openembedded-contrib-fc282987d2ea1695d53017397bb8771f3303c2ff.tar.gz
lv-lib-png: add wayland to REQUIRED_DISTRO_FEATURES
* fixes: ERROR: Nothing PROVIDES 'lvgl' (but meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb DEPENDS on or otherwise requires it) lvgl was skipped: missing required distro feature 'wayland' (not in DISTRO_FEATURES) ERROR: Nothing RPROVIDES 'lv-lib-png-dev' (but meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'lv-lib-png-dev' NOTE: Runtime target 'lv-lib-png-dev' is unbuildable, removing... Missing or unbuildable dependency chain was: ['lv-lib-png-dev'] ERROR: Nothing RPROVIDES 'lv-lib-png' (but meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'lv-lib-png' NOTE: Runtime target 'lv-lib-png' is unbuildable, removing... Missing or unbuildable dependency chain was: ['lv-lib-png'] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb b/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
index ada9423076..084070c436 100644
--- a/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
+++ b/meta-oe/recipes-graphics/lvgl/lv-lib-png_8.0.2.bb
@@ -12,9 +12,13 @@ HOMEPAGE = "https://docs.lvgl.io"
SUMMARY = "PNG decoder for LVGL"
DESCRIPTION = "Allow the use of PNG images in LVGL. This implementation uses lodepng"
+# because of lvgl dependency
+REQUIRED_DISTRO_FEATURES = "wayland"
+
DEPENDS += "lvgl"
inherit cmake
+inherit features_check
TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1"
TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl"