aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-10-25 16:30:22 +0800
committerKhem Raj <raj.khem@gmail.com>2021-10-25 10:40:50 -0700
commit2178fd7386646dc779a075bc65a5008d3b62e027 (patch)
tree7a23bf5c5fc77e9c18671005fce0ad96fb8b38c1
parent6e9d281889cbd5e75308421155eff56f8f72b11b (diff)
downloadmeta-openembedded-contrib-2178fd7386646dc779a075bc65a5008d3b62e027.tar.gz
opencv: remove setup_vars_opencv4.sh
Currently opencv ships with setup_vars_opencv4.sh, but there comes below error: # /usr/bin/setup_vars_opencv4.sh Setting vars for OpenCV 4.5.2 Append PYTHONPATH: /usr/bin/../lib/python3.9/site-packages # ls /usr/bin/../lib/python3.9/site-packages ls: cannot access '/usr/bin/../lib/python3.9/site-packages': No such file or directory Considering the file is useless and also removed in other distribution [1], so remove the file to avoid confusing. [1] https://src.fedoraproject.org/rpms/opencv/blob/rawhide/f/opencv.spec#_424 Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/opencv/opencv_4.5.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_4.5.2.bb b/meta-oe/recipes-support/opencv/opencv_4.5.2.bb
index 361ac0cb95..8d557e0868 100644
--- a/meta-oe/recipes-support/opencv/opencv_4.5.2.bb
+++ b/meta-oe/recipes-support/opencv/opencv_4.5.2.bb
@@ -230,4 +230,8 @@ do_install:append() {
sed -e 's@${STAGING_DIR_HOST}@@g' \
-i ${D}${libdir}/cmake/opencv4/OpenCVModules.cmake
fi
+ # remove setup_vars_opencv4.sh as its content is confusing and useless
+ if [ -f ${D}${bindir}/setup_vars_opencv4.sh ]; then
+ rm -rf ${D}${bindir}/setup_vars_opencv4.sh
+ fi
}