aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-25 10:29:36 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-25 10:40:50 -0700
commit087faa12088cc7c7d9e9addcaf36f1b361e3462e (patch)
tree7898b8053014652d148036f849f8465f69cd2d1c
parent67bc8bd796c79f7e32bafe4d26cf3c111d1ede70 (diff)
downloadmeta-openembedded-contrib-087faa12088cc7c7d9e9addcaf36f1b361e3462e.tar.gz
mozjs: Update to 91.2.0
This has bunch of security fixes https://www.mozilla.org/en-US/security/advisories/mfsa2021-45/ No need to disable jit explicitly for rv32, it works ok without it Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0001-Cargo.toml-do-not-abort-on-panic.patch17
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_91.2.0.bb (renamed from meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_91.1.0.bb)3
2 files changed, 8 insertions, 12 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0001-Cargo.toml-do-not-abort-on-panic.patch b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0001-Cargo.toml-do-not-abort-on-panic.patch
index 34861de7f2..e09848f403 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0001-Cargo.toml-do-not-abort-on-panic.patch
+++ b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs/0001-Cargo.toml-do-not-abort-on-panic.patch
@@ -11,11 +11,15 @@ Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Cargo.toml | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
-diff --git a/Cargo.toml b/Cargo.toml
-index 09f3e7292f..0fff412569 100644
--- a/Cargo.toml
+++ b/Cargo.toml
-@@ -57,7 +57,6 @@ panic = "abort"
+@@ -51,13 +51,11 @@ opt-level = 1
+ rpath = false
+ lto = false
+ debug-assertions = true
+-panic = "abort"
+
+ [profile.release]
opt-level = 2
rpath = false
debug-assertions = false
@@ -23,10 +27,3 @@ index 09f3e7292f..0fff412569 100644
# Optimize build dependencies, because bindgen and proc macros / style
# compilation take more to run than to build otherwise.
-@@ -105,4 +104,4 @@ path = "third_party/rust/mio"
-
- # Patch failure 0.1.8 to disable the backtrace feature by default. See bug 1608157.
- [patch.crates-io.failure]
--path = "third_party/rust/failure"
-\ No newline at end of file
-+path = "third_party/rust/failure"
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_91.1.0.bb b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_91.2.0.bb
index ff0d7bd6ab..45f0145313 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_91.1.0.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_91.2.0.bb
@@ -12,7 +12,7 @@ SRC_URI = "https://archive.mozilla.org/pub/firefox/releases/${PV}esr/source/fire
file://0001-build-do-not-use-autoconf-s-config.sub-to-canonicali.patch \
file://riscv32.patch \
"
-SRC_URI[sha256sum] = "3b913d6a52c95a8986123c98543f1273812a2d59f2891b4b1c604e35f4580766"
+SRC_URI[sha256sum] = "3ef3cfd321d0c2c80ee1b41b8baf7a1ea4daf93c29e1377274933440ff5e42c3"
S = "${WORKDIR}/firefox-${@d.getVar("PV").replace("esr", "")}"
@@ -37,7 +37,6 @@ export RUSTFLAGS
JIT ?= ""
JIT:mipsarch = "--disable-jit"
-JIT:riscv32 = "--disable-jit"
do_configure() {
cd ${B}