aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McDougall <daniel.mcdougall@liftoffsoftware.com>2013-11-19 19:39:57 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-11-24 15:07:23 +0100
commitef44854f921df616621ad80fb6bc9ba7f37a3339 (patch)
treee539906e04617e35bc0182f8c9eedeb1df5f83c8
parentc94ca65829c4bd00b2ec4aef48b9435664d2208e (diff)
downloadmeta-openembedded-contrib-ef44854f921df616621ad80fb6bc9ba7f37a3339.tar.gz
python-futures: New package (provides concurrent.futures)
The python-futures package is a backport of Python 3.2+'s concurrent.futures module to Python 2.6+. Signed-off-by: Dan McDougall <daniel.mcdougall@liftoffsoftware.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-futures_2.1.5.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-futures_2.1.5.bb b/meta-oe/recipes-devtools/python/python-futures_2.1.5.bb
new file mode 100644
index 0000000000..817a9179a2
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-futures_2.1.5.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "The concurrent.futures module provides a high-level interface for asynchronously executing callables."
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e96d16356742ac95c07be571717e51a3"
+HOMEPAGE = "http://code.google.com/p/pythonfutures"
+DEPENDS = "python"
+
+SRC_URI = "https://pypi.python.org/packages/source/f/futures/futures-${PV}.tar.gz"
+SRC_URI[md5sum] = "2fc924890ccd30a5fe676fa9bbcf0ab8"
+SRC_URI[sha256sum] = "8f5a627d3aee94cc1859a942965fdebb714be8cdd2366d819cb8fb9b7cc628a6"
+
+S = "${WORKDIR}/futures-${PV}"
+
+inherit setuptools