aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-01-15 10:47:31 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-22 12:22:34 +0100
commita79ab86e2beed3adc8e001836b1392f510adbe9a (patch)
treee63d887e739384682dbe445506ba34d3bc3111d4
parentd2cc10741b328725418af6ae121c935b54b1f0f6 (diff)
downloadmeta-openembedded-contrib-a79ab86e2beed3adc8e001836b1392f510adbe9a.tar.gz
waffle: remove, migrated to oe-core
Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/waffle/files/cflags.patch27
-rw-r--r--meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb34
2 files changed, 0 insertions, 61 deletions
diff --git a/meta-oe/recipes-graphics/waffle/files/cflags.patch b/meta-oe/recipes-graphics/waffle/files/cflags.patch
deleted file mode 100644
index 3819756748..0000000000
--- a/meta-oe/recipes-graphics/waffle/files/cflags.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Upstream-Status: Backport
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-From 2abec1cb3c17fa5ec8d945d79acd74a39c38293a Mon Sep 17 00:00:00 2001
-From: Ross Burton <ross.burton@intel.com>
-Date: Wed, 12 Dec 2012 12:57:18 +0000
-Subject: cmake: respect existing CMAKE_C_FLAGS
-
-When cross-compiling it's not unusual to need specific arguments passed to gcc
-such as --sysroot. Ensure that these are passed on from the toolchain file by
-appending to CMAKE_C_FLAGS instead of overwriting it.
-
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-Index: waffle-1.2.2/CMakeLists.txt
-===================================================================
---- waffle-1.2.2.orig/CMakeLists.txt 2012-11-28 00:43:40.000000000 +0000
-+++ waffle-1.2.2/CMakeLists.txt 2013-02-13 11:34:02.476188233 +0000
-@@ -212,7 +212,7 @@
- # ------------------------------------------------------------------------------
-
- # FIXME: Only enable c99 if compiler supports it.
--set(CMAKE_C_FLAGS "--std=c99 -Wall -Werror=implicit-function-declaration")
-+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} --std=c99 -Wall -Werror=implicit-function-declaration")
- if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
- # On MacOS, the SSE2 headers trigger this error.
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror=missing-prototypes")
diff --git a/meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb b/meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb
deleted file mode 100644
index 4f80191fdb..0000000000
--- a/meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-SUMMARY = "cross-platform C library to defer selection of GL API and of window system"
-LICENSE = "BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \
- file://include/waffle/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf"
-
-SRC_URI = "http://people.freedesktop.org/~chadversary/waffle/files/release/${BPN}-${PV}/${BPN}-${PV}.tar.xz \
- file://cflags.patch"
-
-SRC_URI[md5sum] = "fdd07cea7709422fbf72418ee63a285d"
-SRC_URI[sha256sum] = "7e342c859b58d4e051b347ef3d7740ed2f3b6c506b93daec272724afe7dd1311"
-
-inherit cmake
-
-# This should be overridden per-machine to reflect the capabilities of the GL
-# stack.
-PACKAGECONFIG ??= "glx"
-
-# I say virtual/libgl, actually wants gl.pc
-PACKAGECONFIG[glx] = "-Dwaffle_has_glx=1,,virtual/libgl libx11"
-
-# I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland
-# DISTRO_FEATURE.
-PACKAGECONFIG[wayland] = "-Dwaffle_has_wayland=1,,virtual/libgl wayland"
-
-# I say virtual/libgl, actually wants gbm.pc egl.pc
-PACKAGECONFIG[gbm] = "-Dwaffle_has_wayland=1,,virtual/libgl udev"
-
-# I say virtual/libgl, actually wants egl.pc
-PACKAGECONFIG[x11-egl] = "-Dwaffle_has_x11_egl=1,,virtual/libgl libxcb"
-
-# Take the flags added by PACKAGECONFIG and pass them to cmake.
-EXTRA_OECMAKE = "${EXTRA_OECONF}"
-
-FILES_${PN}-dev += "${datadir}/cmake/Modules/FindWaffle.cmake"