aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2014-02-11 10:36:52 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-02-21 17:06:59 +0100
commit1f89f0a54e85e540e50bb00305b4163e13b1b4dc (patch)
tree2a26014f755addd39942ddaa47d97f50bd891086
parent34ff6c265a84295a487ead7aa7f858434e703346 (diff)
downloadmeta-openembedded-contrib-1f89f0a54e85e540e50bb00305b4163e13b1b4dc.tar.gz
ltp-ddt: Fix build break with newer kernels
We need to point KERNEL_INC at include-generic otherwise we end up with errors like | from src/parser/st_i2c_parser.c:42: | /home/kraj/work/angstrom-2013.12/build/tmp-angstrom_v2013_12-eglibc/sysroots/beaglebone/usr/src/kernel/include/linux/wait.h:8:25: fatal error: asm/current.h: No such file or directory | #include <asm/current.h> | ^ | compilation terminated. | make[2]: *** [i2c_tests] Error 1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/ltp-ddt/ltp-ddt_0.0.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt_0.0.4.bb b/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt_0.0.4.bb
index c6ddf3db66..da81964406 100644
--- a/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt_0.0.4.bb
+++ b/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt_0.0.4.bb
@@ -12,7 +12,7 @@ inherit autotools
PACKAGE_ARCH = "${MACHINE_ARCH}"
-SRCREV = "5fba3d42f126ce13333fb7d0412d729b753ee5a4"
+SRCREV = "46e8aa7d0dd095300709309301e1c79f0003df40"
BRANCH ?= "master"
SRC_URI = "git://arago-project.org/git/projects/test-automation/ltp-ddt.git;branch=${BRANCH}"
@@ -25,7 +25,7 @@ EXTRA_OEMAKE_append = " \
prefix=${LTPROOT} \
CROSS_COMPILE=${HOST_PREFIX} \
SKIP_IDCHECK=1 \
- KERNEL_INC=${STAGING_KERNEL_DIR}/include \
+ KERNEL_INC=${STAGING_KERNEL_DIR}/include-generic \
KERNEL_USR_INC=${STAGING_INCDIR} \
ALSA_INCPATH=${STAGING_INCDIR} \
ALSA_LIBPATH=${STAGING_LIBDIR} \