aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-27 17:55:01 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-31 08:27:19 -0700
commitd63f4faa5a6e048b195e6a0b963786e82da9c6e0 (patch)
tree9e09055cbcbc97e46d8a6a8b054cec4b9b0962ba
parent2fbcbeb2d6eb446427674e28baa587b7214cdfd6 (diff)
downloadmeta-openembedded-contrib-d63f4faa5a6e048b195e6a0b963786e82da9c6e0.tar.gz
python3-flask-restful: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-flask-restful.inc16
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-restful_0.3.7.bb18
2 files changed, 16 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-restful.inc b/meta-python/recipes-devtools/python/python-flask-restful.inc
deleted file mode 100644
index dcbcd0d761..0000000000
--- a/meta-python/recipes-devtools/python/python-flask-restful.inc
+++ /dev/null
@@ -1,16 +0,0 @@
-SUMMARY = "Simple framework for creating REST APIs"
-DESCRIPTION = "\
-Flask-RESTful is an extension for Flask that adds support for quickly building \
-REST APIs"
-HOMEPAGE = "https://github.com/flask-restful/flask-restful"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=685bb55ed99a366bb431995f5eef2783"
-
-SRC_URI[md5sum] = "a7217ef1159be38af5faf61aa09aabef"
-SRC_URI[sha256sum] = "f8240ec12349afe8df1db168ea7c336c4e5b0271a36982bff7394f93275f2ca9"
-
-inherit pypi
-
-PYPI_PACKAGE = "Flask-RESTful"
-
-RDEPENDS_${PN} = "${PYTHON_PN}-flask"
diff --git a/meta-python/recipes-devtools/python/python3-flask-restful_0.3.7.bb b/meta-python/recipes-devtools/python/python3-flask-restful_0.3.7.bb
index 6bff59a565..ad27578382 100644
--- a/meta-python/recipes-devtools/python/python3-flask-restful_0.3.7.bb
+++ b/meta-python/recipes-devtools/python/python3-flask-restful_0.3.7.bb
@@ -1,2 +1,16 @@
-inherit setuptools3
-require python-flask-restful.inc
+SUMMARY = "Simple framework for creating REST APIs"
+DESCRIPTION = "\
+Flask-RESTful is an extension for Flask that adds support for quickly building \
+REST APIs"
+HOMEPAGE = "https://github.com/flask-restful/flask-restful"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=685bb55ed99a366bb431995f5eef2783"
+
+SRC_URI[md5sum] = "a7217ef1159be38af5faf61aa09aabef"
+SRC_URI[sha256sum] = "f8240ec12349afe8df1db168ea7c336c4e5b0271a36982bff7394f93275f2ca9"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "Flask-RESTful"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-flask"