aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-31 08:31:21 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-31 09:52:38 -0700
commit0bfce1c8eb28cd7c679fe1c1c8b47d6e9b7e6e5e (patch)
treebd9403f8c443bd2074c69e294c68b19855fda7db
parent08779114c958a656a6d439ab488f4bd282a52bf2 (diff)
downloadmeta-openembedded-contrib-0bfce1c8eb28cd7c679fe1c1c8b47d6e9b7e6e5e.tar.gz
lmbench: Use update alternatives for stream
stream is also provided by imagemagick as an alternative Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
index 7e20b7da65..171ac31ac3 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
@@ -5,7 +5,7 @@ LICENSE = "GPLv2 & GPL-2.0-with-lmbench-restriction"
LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
file://COPYING-2;md5=8e9aee2ccc75d61d107e43794a25cdf9"
-inherit autotools-brokensep
+inherit autotools-brokensep update-alternatives
DEPENDS += "libtirpc"
CFLAGS += "-I${STAGING_INCDIR}/tirpc"
@@ -89,3 +89,7 @@ pkg_postinst_${PN} () {
RDEPENDS_${PN} = "perl"
FILES_${PN} += "${datadir}/lmbench"
+
+ALTERNATIVE_${PN} = "stream"
+ALTERNATIVE_LINK_NAME[stream] = "${bindir}/stream"
+