aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-08 08:41:05 -0700
committerKhem Raj <raj.khem@gmail.com>2021-05-11 08:27:27 -0700
commit82a4c2616ef71e404538779aad47b1ceca2911d6 (patch)
tree37794ddff3800f01b49c80e86d521676b4575f02
parent313b98f73c0e0281f86aafe658903a8d7d9daaa1 (diff)
downloadmeta-openembedded-contrib-82a4c2616ef71e404538779aad47b1ceca2911d6.tar.gz
evolution-data-server: Update to 3.40.1
Removed backported patch Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andreas Müller <schnitzeltony@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb1
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc5
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0005-PrintableOptions.cmake-Correct-variable-name-compari.patch67
3 files changed, 2 insertions, 71 deletions
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
index e2d7f502bd..7f267b4972 100644
--- a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
@@ -16,7 +16,6 @@ SRC_URI += " \
file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \
file://0004-call-native-helpers.patch \
file://iconv-detect.h \
- file://0005-PrintableOptions.cmake-Correct-variable-name-compari.patch \
"
LKSTRFTIME = "HAVE_LKSTRFTIME=ON"
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc
index f39440cc6f..870a9c0e94 100644
--- a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc
@@ -9,6 +9,5 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6a6e689d19255cf0557f3fe7d7068212 \
inherit gnomebase upstream-version-is-even
-SRC_URI[archive.sha256sum] = "c555528c546d457be0dc0eaca5d766d4dfef7c408276cb05f9724c463bfe7fd9"
-PV = "3.36.5"
-
+SRC_URI[archive.sha256sum] = "eac75f348aa5defbe9473fa30ab6084635ee64d8e3eaaec60a62c27f149c3e22"
+PV = "3.40.1"
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0005-PrintableOptions.cmake-Correct-variable-name-compari.patch b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0005-PrintableOptions.cmake-Correct-variable-name-compari.patch
deleted file mode 100644
index d84b41d003..0000000000
--- a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0005-PrintableOptions.cmake-Correct-variable-name-compari.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From c95a70bfeae25ba11fbe50fe759a6cdb29388e44 Mon Sep 17 00:00:00 2001
-From: Milan Crha <mcrha@redhat.com>
-Date: Wed, 14 Apr 2021 16:58:08 +0200
-Subject: [PATCH] PrintableOptions.cmake: Correct variable name comparison
-
-CMake 3.20.1 errors out with:
-
-CMake Error at cmake/modules/PrintableOptions.cmake:38 (message):
- variable name cannot be empty
- Call Stack (most recent call first):
- CMakeLists.txt:152 (add_printable_variable)
-
-Change how the parameter value is compared, to fix it.
-
-Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/evolution-data-server/-/commit/c95a70bfeae25ba11fbe50fe759a6cdb29388e44]
----
- cmake/modules/PrintableOptions.cmake | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/cmake/modules/PrintableOptions.cmake b/cmake/modules/PrintableOptions.cmake
-index a79419a..c74531a 100644
---- a/cmake/modules/PrintableOptions.cmake
-+++ b/cmake/modules/PrintableOptions.cmake
-@@ -19,32 +19,32 @@
- # prints all the build options previously added with the above functions
-
- macro(add_printable_variable_bare _name)
-- if(_name STREQUAL "")
-+ if("${_name}" STREQUAL "")
- message(FATAL_ERROR "variable name cannot be empty")
-- endif(_name STREQUAL "")
-+ endif("${_name}" STREQUAL "")
- list(APPEND _printable_options ${_name})
- endmacro()
-
- macro(add_printable_option _name _description _default_value)
-- if(_name STREQUAL "")
-+ if("${_name}" STREQUAL "")
- message(FATAL_ERROR "option name cannot be empty")
-- endif(_name STREQUAL "")
-+ endif("${_name}" STREQUAL "")
- option(${_name} ${_description} ${_default_value})
- add_printable_variable_bare(${_name})
- endmacro()
-
- macro(add_printable_variable _name _description _default_value)
-- if(_name STREQUAL "")
-+ if("${_name}" STREQUAL "")
- message(FATAL_ERROR "variable name cannot be empty")
-- endif(_name STREQUAL "")
-+ endif("${_name}" STREQUAL "")
- set(${_name} ${_default_value} CACHE STRING ${_description})
- add_printable_variable_bare(${_name})
- endmacro()
-
- macro(add_printable_variable_path _name _description _default_value)
-- if(_name STREQUAL "")
-+ if("${_name}" STREQUAL "")
- message(FATAL_ERROR "path variable name cannot be empty")
-- endif(_name STREQUAL "")
-+ endif("${_name}" STREQUAL "")
- set(${_name} ${_default_value} CACHE PATH ${_description})
- add_printable_variable_bare(${_name})
- endmacro()
---
-2.30.2
-