aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-23 12:39:49 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-26 01:04:52 +0100
commitd361ef01a9a61cd8a83f7728f7d3e9f118233cb8 (patch)
treefc87bd4653a60f180ae525fa96f4cb126efd3018
parentac2abd467ec0e88e0c3663a55d38d9bfcbfe4618 (diff)
downloadmeta-openembedded-contrib-d361ef01a9a61cd8a83f7728f7d3e9f118233cb8.tar.gz
nis, opencv: Update getVar/setVar syntax
The deprecated APIs are removed from bitbake, update two old style references in meta-oe/meta-networking. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-networking/recipes-support/nis/nis.inc2
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.1.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/nis/nis.inc b/meta-networking/recipes-support/nis/nis.inc
index c4aa10e3a2..e027a1c6f8 100644
--- a/meta-networking/recipes-support/nis/nis.inc
+++ b/meta-networking/recipes-support/nis/nis.inc
@@ -25,7 +25,7 @@ do_install() {
# so force the package to be skipped here (this will cause a
# 'nothing provides' error)
python () {
- os = bb.data.getVar("TARGET_OS", d, 1)
+ os = d.getVar("TARGET_OS", True)
if os == "linux-uclibc":
raise bb.parse.SkipPackage("NIS functionality requires rpcsvc/yp.h, uClibC does not provide this")
}
diff --git a/meta-oe/recipes-support/opencv/opencv_3.1.bb b/meta-oe/recipes-support/opencv/opencv_3.1.bb
index a212f4f9d1..74e30e4170 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.1.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.1.bb
@@ -106,7 +106,7 @@ python populate_packages_prepend () {
for pkg in packages[1:]:
if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.endswith('-dev') and not pkg.endswith('-dbg') and not pkg.endswith('-doc') and not pkg.endswith('-locale'):
metapkg_rdepends.append(pkg)
- bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
+ d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends))
}