aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-11-14 17:50:21 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-26 01:07:04 +0100
commit5d22f066174e12799c11466dc37b6111a5864118 (patch)
tree8bcd6f00fdc9418a6453c5b8e5d9a90413577d73
parente4f6f96f9056704a3afea0917b28ca483ccc8309 (diff)
downloadmeta-openembedded-contrib-5d22f066174e12799c11466dc37b6111a5864118.tar.gz
openldap: Fix Build error due to missing -fPIC
Fixes errors e.g. relocation R_AARCH64_ADR_PREL_PG_HI21 against external symbol `stderr@@GLIBC_2.17' can not be us ed when making a shared object; recompile with -fPIC Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/openldap/openldap_2.4.44.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.44.bb b/meta-oe/recipes-support/openldap/openldap_2.4.44.bb
index 4e95a775c1..05ffc5ce3b 100644
--- a/meta-oe/recipes-support/openldap/openldap_2.4.44.bb
+++ b/meta-oe/recipes-support/openldap/openldap_2.4.44.bb
@@ -148,7 +148,7 @@ PACKAGES += "${PN}-overlay-proxycache"
# Append URANDOM_DEVICE='/dev/urandom' to CPPFLAGS:
# This allows tls to obtain random bits from /dev/urandom, by default
# it was disabled for cross-compiling.
-CPPFLAGS_append = " -D_GNU_SOURCE -DURANDOM_DEVICE=\'/dev/urandom\'"
+CPPFLAGS_append = " -D_GNU_SOURCE -DURANDOM_DEVICE=\'/dev/urandom\' -fPIC"
LDFLAGS += "-pthread"