aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-11-23 14:13:39 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-02 09:16:18 +0100
commit533826b7652a2cf86ca7b665c25b98c89afc266e (patch)
tree95a8341dd6b9f8864c2617086c97f7e1fbb6d615
parentfc2fc9097b2fa437d4af0338e418692b4dd6c989 (diff)
downloadmeta-openembedded-contrib-533826b7652a2cf86ca7b665c25b98c89afc266e.tar.gz
meta-oe: add explicit dependencies on gnome-common
gnome-common is deprecated and gnomebase.bbclass will soon stop depending on it, so add gnome-common to DEPENDS for the recipes that still use it. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb3
-rw-r--r--meta-oe/recipes-extended/libgxim/libgxim_0.5.0.bb2
-rw-r--r--meta-oe/recipes-gnome/vte9/vte9.inc3
3 files changed, 3 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb b/meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb
index 77416d45bf..e490ae50b7 100644
--- a/meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb
+++ b/meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb
@@ -8,7 +8,7 @@ inherit autotools pkgconfig gnomebase distutils-base gobject-introspection
PYTHON_BASEVERSION = "2.7"
PYTHON_PN = "python"
-DEPENDS += "python glib-2.0"
+DEPENDS += "gnome-common-native python glib-2.0"
SRCNAME="pygobject"
SRC_URI = " \
@@ -31,4 +31,3 @@ do_install_append() {
# Remove files that clash with python3-pygobject; their content is same
rm ${D}${includedir}/pygobject-3.0/pygobject.h ${D}${libdir}/pkgconfig/pygobject-3.0.pc
}
-
diff --git a/meta-oe/recipes-extended/libgxim/libgxim_0.5.0.bb b/meta-oe/recipes-extended/libgxim/libgxim_0.5.0.bb
index 772babf5bb..1d5ae95d97 100644
--- a/meta-oe/recipes-extended/libgxim/libgxim_0.5.0.bb
+++ b/meta-oe/recipes-extended/libgxim/libgxim_0.5.0.bb
@@ -20,6 +20,6 @@ LIC_FILES_CHKSUM = "\
file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
EXTRA_OECONF = " --disable-static --disable-rebuilds"
-DEPENDS += "gtk+ glib-2.0 ruby-native intltool-native"
+DEPENDS += "gtk+ glib-2.0 ruby-native intltool-native gnome-common-native"
inherit autotools pkgconfig gettext
diff --git a/meta-oe/recipes-gnome/vte9/vte9.inc b/meta-oe/recipes-gnome/vte9/vte9.inc
index 6a5c63cf98..206c430da6 100644
--- a/meta-oe/recipes-gnome/vte9/vte9.inc
+++ b/meta-oe/recipes-gnome/vte9/vte9.inc
@@ -1,7 +1,7 @@
SUMMARY = "Virtual terminal emulator GTK+ widget library"
BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte"
LICENSE = "LGPLv2.0"
-DEPENDS = " glib-2.0 gtk+ intltool-native ncurses"
+DEPENDS = " glib-2.0 gtk+ intltool-native gnome-common-native ncurses"
RDEPENDS_libvte = "vte-termcap"
# help gnomebase get the SRC_URI correct
@@ -16,4 +16,3 @@ EXTRA_OECONF = "--disable-python"
PACKAGES =+ "libvte9 vte9-termcap"
FILES_libvte9 = "${libdir}/*.so.* ${libexecdir}/gnome-pty-helper"
FILES_vte9-termcap = "${datadir}/vte/termcap-0.0"
-