aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-11-22 07:32:30 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-02 09:23:43 +0100
commit41d7bac5d50091cab835eac0a5eaa6c431fb2023 (patch)
tree35050267acc6a0ef9c1bd8020b3a14a17937dcef
parent86fed80d80bc33f0a3cdbf719c00ee5f05ed4d19 (diff)
downloadmeta-openembedded-contrib-41d7bac5d50091cab835eac0a5eaa6c431fb2023.tar.gz
memcached: Update to 1.4.33
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/memcached/memcached/configure.patch13
-rw-r--r--meta-networking/recipes-support/memcached/memcached/redundant_comparison.patch13
-rw-r--r--meta-networking/recipes-support/memcached/memcached_1.4.33.bb (renamed from meta-networking/recipes-support/memcached/memcached_1.4.17.bb)7
3 files changed, 16 insertions, 17 deletions
diff --git a/meta-networking/recipes-support/memcached/memcached/configure.patch b/meta-networking/recipes-support/memcached/memcached/configure.patch
deleted file mode 100644
index 7001a0ed65..0000000000
--- a/meta-networking/recipes-support/memcached/memcached/configure.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: memcached-1.4.17/configure.ac
-===================================================================
---- memcached-1.4.17.orig/configure.ac 2013-12-20 21:44:49.000000000 +0000
-+++ memcached-1.4.17/configure.ac 2014-07-18 07:17:00.593499483 +0000
-@@ -4,7 +4,7 @@
- AC_INIT(memcached, VERSION_NUMBER, memcached@googlegroups.com)
- AC_CANONICAL_SYSTEM
- AC_CONFIG_SRCDIR(memcached.c)
--AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
-+AM_INIT_AUTOMAKE([foreign])
- AM_CONFIG_HEADER(config.h)
-
- AC_PROG_CC
diff --git a/meta-networking/recipes-support/memcached/memcached/redundant_comparison.patch b/meta-networking/recipes-support/memcached/memcached/redundant_comparison.patch
new file mode 100644
index 0000000000..ed86ffae4d
--- /dev/null
+++ b/meta-networking/recipes-support/memcached/memcached/redundant_comparison.patch
@@ -0,0 +1,13 @@
+Index: memcached-1.4.33/items.c
+===================================================================
+--- memcached-1.4.33.orig/items.c
++++ memcached-1.4.33/items.c
+@@ -148,7 +148,7 @@ item *do_item_alloc(char *key, const siz
+ uint8_t nsuffix;
+ item *it = NULL;
+ char suffix[40];
+- if (nbytes < 2 || nkey < 0)
++ if (nbytes < 2)
+ return 0;
+
+ size_t ntotal = item_make_header(nkey + 1, flags, nbytes, suffix, &nsuffix);
diff --git a/meta-networking/recipes-support/memcached/memcached_1.4.17.bb b/meta-networking/recipes-support/memcached/memcached_1.4.33.bb
index 2b36ba4f86..da9a693ac7 100644
--- a/meta-networking/recipes-support/memcached/memcached_1.4.17.bb
+++ b/meta-networking/recipes-support/memcached/memcached_1.4.33.bb
@@ -20,15 +20,14 @@ RDEPENDS_${PN} += "perl perl-module-posix perl-module-autoloader \
"
SRC_URI = "http://www.memcached.org/files/${BP}.tar.gz \
- file://configure.patch \
+ file://redundant_comparison.patch \
file://memcached-add-hugetlbfs-check.patch"
+SRC_URI[md5sum] = "2d7f6476283cd36e21e521d901d37a8f"
+SRC_URI[sha256sum] = "83726c8d68258c56712373072abb25a449c257398075a39ec0867fd8ba69771d"
# set the same COMPATIBLE_HOST as libhugetlbfs
COMPATIBLE_HOST = '(i.86|x86_64|powerpc|powerpc64|arm).*-linux'
-SRC_URI[md5sum] = "46402dfbd7faadf6182283dbbd18b1a6"
-SRC_URI[sha256sum] = "d9173ef6d99ba798c982ea4566cb4f0e64eb23859fdbf9926a89999d8cdc0458"
-
python __anonymous () {
endianness = d.getVar('SITEINFO_ENDIANNESS')
if endianness == 'le':