aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-04-04 19:54:16 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-11 10:30:21 +0200
commitbf6aa3c1eb1224caf593994d859bbb2fbb735d6c (patch)
treed60337b5e2ee2d450f88de6d726988d74e466903
parent5dd01c5175f518658d8ee5627ede4f593111b872 (diff)
downloadmeta-openembedded-contrib-bf6aa3c1eb1224caf593994d859bbb2fbb735d6c.tar.gz
protobuf: update update and build fix
googlecode is shutting down so had to move SRC_URI to github. changed LIC_FILES_CHKSUM to LICENSE since COPY.TXT has been removed. updated fixed the following build issue: | tmp/work/ppc7400-poky-linux/protobuf/2.5.0-r0/protobuf-2.5.0/src/google/protobuf/extension_set.cc:81:3: error: 'GoogleOnceInit' is not a member of 'google::protobuf' | ::google::protobuf::GoogleOnceInit(&registry_init_, &InitRegistry); | ^ | tmp/work/ppc7400-poky-linux/protobuf/2.5.0-r0/protobuf-2.5.0/src/google/protobuf/extension_set.cc:81:39: error: 'registry_init_' was not declared in this scope | ::google::protobuf::GoogleOnceInit(&registry_init_, &InitRegistry); | ^ Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf_2.6.1.bb (renamed from meta-oe/recipes-devtools/protobuf/protobuf_2.5.0.bb)13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf_2.5.0.bb b/meta-oe/recipes-devtools/protobuf/protobuf_2.6.1.bb
index a0db7bf95d..049f9d4e8f 100644
--- a/meta-oe/recipes-devtools/protobuf/protobuf_2.5.0.bb
+++ b/meta-oe/recipes-devtools/protobuf/protobuf_2.6.1.bb
@@ -2,21 +2,24 @@ SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
DESCRIPTION = "Protocol Buffers are a way of encoding structured data in an \
efficient yet extensible format. Google uses Protocol Buffers for almost \
all of its internal RPC protocols and file formats."
-HOMEPAGE = "http://code.google.com/p/protobuf/"
+HOMEPAGE = "https://github.com/google/protobuf"
SECTION = "console/tools"
LICENSE = "BSD-3-Clause"
DEPENDS = "zlib"
-LIC_FILES_CHKSUM = "file://COPYING.txt;md5=af6809583bfde9a31595a58bb4a24514"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=af6809583bfde9a31595a58bb4a24514"
-SRC_URI = "http://protobuf.googlecode.com/files/protobuf-${PV}.tar.gz"
+SRCREV = "bba83652e1be610bdb7ee1566ad18346d98b843c"
-SRC_URI[md5sum] = "b751f772bdeb2812a2a8e7202bf1dae8"
-SRC_URI[sha256sum] = "c55aa3dc538e6fd5eaf732f4eb6b98bdcb7cedb5b91d3b5bdcf29c98c293f58e"
+PV = "2.6.1+git${SRCPV}"
+
+SRC_URI = "git://github.com/google/protobuf.git"
EXTRA_OECONF += " --with-protoc=echo"
inherit autotools
+S = "${WORKDIR}/git"
+
BBCLASSEXTEND = "native nativesdk"