aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-10-01 01:28:39 -0400
committerKhem Raj <raj.khem@gmail.com>2019-10-01 08:51:18 -0700
commit1f80fd9618efef1f6b0967f69afe88669a963e67 (patch)
tree8a7eb0573eb7af42c2594509a9b8575fcc19b7fa
parent9bdbf7b485ed1e3241288bff614aeb3fc6039b1b (diff)
downloadmeta-openembedded-contrib-1f80fd9618efef1f6b0967f69afe88669a963e67.tar.gz
rwmem: add recipe
This is being moved from meta-ti as it's a rather generic tool to be useful on other platforms. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-bsp/rwmem/rwmem_1.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/rwmem/rwmem_1.2.bb b/meta-oe/recipes-bsp/rwmem/rwmem_1.2.bb
new file mode 100644
index 0000000000..0a15134df8
--- /dev/null
+++ b/meta-oe/recipes-bsp/rwmem/rwmem_1.2.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A small tool to read/write memory"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS += "python3 python3-pybind11"
+
+PV .= "+git${SRCPV}"
+
+SRCREV_rwmem = "cc296c5366a35a4c4271cfa3cc9831f6f34bfd9d"
+SRCREV_inih = "4b10c654051a86556dfdb634c891b6c3224c4109"
+
+SRCREV_FORMAT = "rwmem_inih"
+
+SRC_URI = " \
+ git://github.com/tomba/rwmem.git;protocol=https;name=rwmem \
+ git://github.com/benhoyt/inih.git;protocol=https;name=inih;nobranch=1;destsuffix=git/ext/inih \
+"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+do_install() {
+ install -D -m 0755 ${B}/bin/rwmem ${D}${bindir}/rwmem
+ install -D -m 0644 ${B}/lib/librwmem.a ${D}${libdir}/librwmem.a
+}