aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-07-11 13:52:57 +0800
committerArmin Kuster <akuster808@gmail.com>2019-09-02 19:39:29 -0700
commit779f35fa10b8e920a2a9b86c865f48e6ba5f2595 (patch)
treee81770ff0da064a0ce760a7445d20eb0c609be2e
parent23a2e95963ad32e918a9eb3e7412221d56f7a735 (diff)
downloadmeta-openembedded-contrib-779f35fa10b8e920a2a9b86c865f48e6ba5f2595.tar.gz
satyr: fix "Nothing RPROVIDES" when multilib enabled
Multilib enabled, and add IMAGE_INSTALL_append = " python3-satyr" in local.conf fix below problem: ERROR: Required build target 'lib32-core-image-minimal' has no buildable providers. Missing or unbuildable dependency chain was: ['lib32-core-image-minimal', 'lib32-python3-satyr'] Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/satyr/satyr_0.27.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/satyr/satyr_0.27.bb b/meta-oe/recipes-support/satyr/satyr_0.27.bb
index 10dfc2bade..cc07dcb06e 100644
--- a/meta-oe/recipes-support/satyr/satyr_0.27.bb
+++ b/meta-oe/recipes-support/satyr/satyr_0.27.bb
@@ -19,8 +19,8 @@ DEPENDS += " \
gdb \
"
-PACKAGES += "python3-${PN}"
-FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
+PACKAGES += "python3-${BPN}"
+FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
PACKAGECONFIG ??= "python3 rpm"
PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"