aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-08-28 18:27:42 -0700
committerArmin Kuster <akuster808@gmail.com>2019-10-05 07:46:00 -0700
commit0d053082ab13a2668ecc94adbc6d6dd862be1c41 (patch)
tree64c2dcb6858a1815817b92e05d5a4d21bd22b977
parent73c59ca02131bf1332f059808423af49324a249f (diff)
downloadmeta-openembedded-contrib-0d053082ab13a2668ecc94adbc6d6dd862be1c41.tar.gz
bpftool.bb: Disable SECURITY_CFLAGS
We do not pass CFLAGS to build and fortify sources needs some optimization to be enabled, its better to reset the additional flags and let the build system add them as it needs Fixes build failures like tools/include/tools/libc_compat.h:11:21: error: static declaration of 'reallocarray' follows non-static declaration | 11 | static inline void *reallocarray(void *ptr, size_t nmemb, size_t size) | | ^~~~~~~~~~~~ Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit d46e1e767f6b91dc25935e0c48d9d362dd50d879) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-kernel/bpftool/bpftool.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-kernel/bpftool/bpftool.bb b/meta-oe/recipes-kernel/bpftool/bpftool.bb
index f75ac6f81c..a5df547865 100644
--- a/meta-oe/recipes-kernel/bpftool/bpftool.bb
+++ b/meta-oe/recipes-kernel/bpftool/bpftool.bb
@@ -10,7 +10,9 @@ inherit bash-completion kernelsrc kernel-arch
do_populate_lic[depends] += "virtual/kernel:do_patch"
-EXTRA_OEMAKE = "-C ${S}/tools/bpf/bpftool O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
+EXTRA_OEMAKE = "V=1 -C ${S}/tools/bpf/bpftool O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
+
+SECURITY_CFLAGS = ""
do_configure[depends] += "virtual/kernel:do_shared_workdir"