aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAsh Charles <ashcharles@gmail.com>2014-05-27 09:56:48 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-10 12:27:19 +0200
commit351bc35e25d8667d435232a0a76e2ab998f7043b (patch)
treef36a2c9b1da19804b34c2b789b3e96adf932caad
parent14af1771aad8e580837189155835f212a401e869 (diff)
downloadmeta-openembedded-contrib-351bc35e25d8667d435232a0a76e2ab998f7043b.tar.gz
network-manager-applet: fix S!=B error
The Makefile fixup in do_configure_append is in the build directory, not the source directory. Signed-off-by: Ash Charles <ashcharles@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_0.9.8.0.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_0.9.8.0.bb b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_0.9.8.0.bb
index 6c0028322e..8dbb3dcdeb 100644
--- a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_0.9.8.0.bb
+++ b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_0.9.8.0.bb
@@ -24,7 +24,7 @@ EXTRA_OECONF += " \
do_configure_append() {
rm config.log
# Sigh... --enable-compile-warnings=no doesn't actually turn off -Werror
- for i in $(find ${S} -name "Makefile") ; do
+ for i in $(find ${B} -name "Makefile") ; do
sed -i -e s:-Werror::g $i
done
}
@@ -45,4 +45,3 @@ FILES_${PN} += "${libdir}/gnome-bluetooth/plugins/*.so"
FILES_${PN}-dev += "${libdir}/gnome-bluetooth/plugins/libnma.la"
FILES_${PN}-staticdev += "${libdir}/gnome-bluetooth/plugins/libnma.a"
FILES_${PN}-dbg += "${libdir}/gnome-bluetooth/plugins/.debug/"
-