aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Varnin <fenixk19@mail.ru>2015-02-05 19:27:24 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 15:22:59 +0200
commit714ba6ecdbc60d257c5ef473c95a76072a3563a1 (patch)
tree18370b36fb9d848791bffdcaa6a0c3770a3c5c34
parenta4eaee2034ae8f7b5f3a9f363c3768865da327a6 (diff)
downloadmeta-openembedded-contrib-714ba6ecdbc60d257c5ef473c95a76072a3563a1.tar.gz
unixodbc: add new recipe
UnixODBC is an implementation of the Open Database Connectivity standard, a database abstraction layer that allows applications to be used with many different relational databases by way of a single library. Signed-off-by: Alexander Varnin <fenixk19@mail.ru> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/unixodbc/unixodbc_2.3.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/unixodbc/unixodbc_2.3.2.bb b/meta-oe/recipes-extended/unixodbc/unixodbc_2.3.2.bb
new file mode 100644
index 0000000000..f9b0069ad4
--- /dev/null
+++ b/meta-oe/recipes-extended/unixodbc/unixodbc_2.3.2.bb
@@ -0,0 +1,23 @@
+SUMMARY = "UnixODBC is an implementation of the Open Database Connectivity standard, a database abstraction layer that allows applications to be used with many different relational databases by way of a single library."
+HOMEPAGE = "http://www.unixodbc.org"
+LICENSE = "GPLv2"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=d7b37bf80a3df5a65b355433ae36d206"
+
+SRC_URI = "ftp://ftp.unixodbc.org/pub/unixODBC/unixODBC-${PV}.tar.gz"
+SRC_URI[md5sum] = "5e4528851eda5d3d4aed249b669bd05b"
+SRC_URI[sha256sum] = "9c3459742f25df5aa3c10a61429bde51a6d4f11552c03095f1d33d7eb02b5c9a"
+
+S = "${WORKDIR}/unixODBC-${PV}"
+
+inherit autotools
+
+do_configure() {
+ gnu-configize --force
+ libtoolize --force --copy
+ aclocal
+ autoconf
+ automake --add-missing
+ oe_runconf
+}
+