aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank de Brabander <debrabander@gmail.com>2022-09-26 10:08:26 +0200
committerKhem Raj <raj.khem@gmail.com>2022-09-26 18:14:53 -0700
commitc350665f61ab3e6f36b131852d7e388f90476ef7 (patch)
tree371bc4dca8372441472ea40313eed972dcc007d5
parentc0d2a5bcc87ee8564a5b9be35f3e2b930e384a59 (diff)
downloadmeta-openembedded-contrib-c350665f61ab3e6f36b131852d7e388f90476ef7.tar.gz
ntp: add missing runtime dependency on libgcc for sntp
This runtime dependency was already added for ntpd but not yet for the sntp binary. This will result in an error when pthread_exit() is called: "libgcc_s.so.1 must be installed for pthread_cancel to work" Signed-off-by: Frank de Brabander <debrabander@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb
index 50f5477f27..2ae53dc640 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb
@@ -139,8 +139,9 @@ PACKAGES += "ntpdate sntp ntpdc ntpq ${PN}-tickadj ${PN}-utils"
# ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms
# with wonky clocks (e.g. OpenSlug)
RDEPENDS:${PN} = "${PN}-tickadj"
-# ntpd require libgcc for execution
+# ntpd & sntp require libgcc for execution due to phtread_cancel/pthread_exit calls
RDEPENDS:${PN} += "libgcc"
+RDEPENDS:sntp += "libgcc"
# Handle move from bin to utils package
RPROVIDES:${PN}-utils = "${PN}-bin"
RREPLACES:${PN}-utils = "${PN}-bin"