aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-06 15:33:27 +0300
committerTrevor Gamblin <trevor.gamblin@windriver.com>2021-04-08 08:54:52 -0400
commitb8230b6a66018b370fdae7e32e7e5286234afe78 (patch)
treef0eb300fd03862873dc03c2e619159049ca445d1
parenta23fa069d0a60cf348dcc6399f7990de59105c21 (diff)
downloadmeta-openembedded-contrib-b8230b6a66018b370fdae7e32e7e5286234afe78.tar.gz
python3-sqlalchemy: Upgrade 1.4.4 -> 1.4.5
Upgrade to release 1.4.5: orm: - Fixed regression where the joinedload() loader strategy would not successfully joinedload to a mapper that is mapper against a CTE construct. - Scaled back the warning message added in #5171 to not warn for overlapping columns in an inheritance scenario where a particular relationship is local to a subclass and therefore does not represent an overlap. sql: - Fixed bug in new FunctionElement.render_derived() feature where column names rendered out explicitly in the alias SQL would not have proper quoting applied for case sensitive names and other non-alphanumeric names. - Fixed regression where use of the Operators.in_() method with a Select object against a non-table-bound column would produce an AttributeError, or more generally using a ScalarSelect that has no datatype in a binary expression would produce invalid state. - Added a new flag to the Dialect class called Dialect.supports_statement_cache. This flag now needs to be present directly on a dialect class in order for SQLAlchemy's query cache to take effect for that dialect. The rationale is based on discovered issues such as #6173 revealing that dialects which hardcode literal values from the compiled statement, often the numerical parameters used for LIMIT / OFFSET, will not be compatible with caching until these dialects are revised to use the parameters present in the statement only. For third party dialects where this flag is not applied, the SQL logging will show the message "dialect does not support caching", indicating the dialect should seek to apply this flag once they have verified that no per-statement literal values are being rendered iwithin the compilation phase. schema: - Introduce a new parameter Enum.omit_aliases in Enum type allow filtering aliases when using a pep435 Enum. Previous versions of SQLAlchemy kept aliases in all cases, creating database enum type with additional states, meaning that they were treated as different values in the db. For backward compatibility this flag defaults to False in the 1.4 series, but will be switched to True in a future version. A deprecation warning is raise if this iflag is not specified and the passed enum contains aliases. mypy: - Fixed issue in mypy plugin where newly added support for as_declarative() needed to more fully add the DeclarativeMeta class to the mypy interpreter’s state so that it does not result in a name not found error; additionally improves how global names are setup for the plugin including the Mapped name. asyncio: - Fixed issue where the asyncio extension could not be loaded if running Python 3.6 with the backport library of contextvars installed. postgresql: - Fixed regression where the PostgreSQL cast operator applied to elements within an ARRAY when using psycopg2 would fail to use the correct type in the case that the datatype were also embedded within an instance of the Variant adapter. - Fixed typo in the fix released in 1.4.4 that completely prevented this change from working correctly, i.e. the error message did not match what was actually emitted by pg8000. - Fixed issue where the PostgreSQL PGInspector, when generated against an Engine, would fail for .get_enums(), .get_view_names(), .get_foreign_table_names() and .get_table_oid() when used against a "future" style engine and not the connection directly. mysql: - Fixed regression in the MySQL dialect where the reflection query used to detect if a table exists would fail on very old MySQL 5.0 and 5.1 versions. mssql: - Fixed a regression in MSSQL 2012+ that prevented the order by clause to be rendered when offset=0 is used in a subquery. oracle: - Fixed critical regression where the Oracle compiler would not maintain the correct parameter values in the LIMIT/OFFSET for a select due to a caching issue. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.5.bb (renamed from meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.4.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.4.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.5.bb
index 1578da5e57..206a9ab3b0 100644
--- a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.4.bb
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.5.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.sqlalchemy.org/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3359ed561ac16aaa25b6c6eff84df595"
-SRC_URI[sha256sum] = "7ba9c00c129dbb4fd026a1f2c943188db59c802612e49bc9bded426d8eb14bc0"
+SRC_URI[sha256sum] = "1294f05916c044631fd626a4866326bbfbd17f62bd37510d000afaef4b35bd74"
PYPI_PACKAGE = "SQLAlchemy"
inherit pypi setuptools3