aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2019-12-02 19:33:40 +0000
committerKhem Raj <raj.khem@gmail.com>2019-12-03 09:31:53 -0800
commita977b60045714eed1498aaec020eae913ea65ebf (patch)
tree74a9d45a833bfa28e7c85b26aee5bfb105725315
parentf6df0263f768108db5c5b8c098ef0d4c699841a4 (diff)
downloadmeta-openembedded-contrib-a977b60045714eed1498aaec020eae913ea65ebf.tar.gz
ostree: Drop tests for soup/xattr with ptest
When ptest is enabled, both soup (for trivial-httpd) and xattr must be enabled for all tests to pass. Rather than forcing everyone to enable these, just document this and remove the tests since a subset of the tests are still useful. Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/ostree/ostree_2019.5.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree_2019.5.bb b/meta-oe/recipes-extended/ostree/ostree_2019.5.bb
index b2bfaaf051..ac1e490480 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2019.5.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2019.5.bb
@@ -42,6 +42,8 @@ inherit autotools bash-completion gobject-introspection gtk-doc pkgconfig ptest-
# Package configuration - match ostree defaults, but without rofiles-fuse
# otherwise we introduce a dependendency on meta-filesystems
+#
+# If running with ptest, both soup (for trivial-httpd) and xattr are required
PACKAGECONFIG ??= " \
${@bb.utils.filter('DISTRO_FEATURES', 'selinux smack', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd libmount', '', d)} \
@@ -185,8 +187,4 @@ python __anonymous() {
if bb.utils.contains('PTEST_ENABLED', '1', 'True', '', d):
if not bb.utils.contains_any('BBFILE_COLLECTIONS', 'meta-python', 'True', '', d):
raise bb.parse.SkipRecipe('ptest requires meta-python to be present.')
- elif not bb.utils.contains_any('PACKAGECONFIG', 'soup curl', 'True', 'False', d):
- raise bb.parse.SkipRecipe('ptest requires soup enabled in PACKAGECONFIG.')
- elif not oe.utils.any_distro_features(d, "xattr"):
- raise bb.parse.SkipRecipe('ptest requires xattr enabled in DISTRO_FEATURES.')
}