aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2019-12-04 07:02:17 -0800
committerKhem Raj <raj.khem@gmail.com>2019-12-05 23:01:06 -0800
commit8bbd98b2bb216498653ea9b5f66eecb11d63feeb (patch)
tree1d90a1eb4ff2c0f9e15640d1379e2381f3c20d64
parent40b3a5123120da0e45862a534abd42fa77c6fb6c (diff)
downloadmeta-openembedded-contrib-8bbd98b2bb216498653ea9b5f66eecb11d63feeb.tar.gz
python-jsonschema: 3.1.1 -> 3.2.0
0001-setup.cfg-add-non-GPL-format-option.patch Removed since it is included in 3.2.0 Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema.inc6
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema/0001-setup.cfg-add-non-GPL-format-option.patch96
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema_3.2.0.bb (renamed from meta-python/recipes-devtools/python/python-jsonschema_3.1.1.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonschema_3.2.0.bb (renamed from meta-python/recipes-devtools/python/python3-jsonschema_3.1.1.bb)0
4 files changed, 2 insertions, 100 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonschema.inc b/meta-python/recipes-devtools/python/python-jsonschema.inc
index 258beadc43..8135b0fe65 100644
--- a/meta-python/recipes-devtools/python/python-jsonschema.inc
+++ b/meta-python/recipes-devtools/python/python-jsonschema.inc
@@ -7,10 +7,8 @@ DEPENDS += "${PYTHON_PN}-vcversioner-native ${PYTHON_PN}-setuptools-scm-native"
FILESEXTRAPATHS_prepend := "${THISDIR}/python-jsonschema:"
-SRC_URI_append = " file://0001-setup.cfg-add-non-GPL-format-option.patch"
-
-SRC_URI[md5sum] = "a802ab85600074a726ef6acc4e6a8148"
-SRC_URI[sha256sum] = "2fa0684276b6333ff3c0b1b27081f4b2305f0a36cf702a23db50edb141893c3f"
+SRC_URI[md5sum] = "f1a0b5011f05a02a8dee1070cd10a26d"
+SRC_URI[sha256sum] = "c8a85b28d377cc7737e46e2d9f2b4f44ee3c0e1deac6bf46ddefc7187d30797a"
PACKAGECONFIG ??= "format"
PACKAGECONFIG[format] = ",,,\
diff --git a/meta-python/recipes-devtools/python/python-jsonschema/0001-setup.cfg-add-non-GPL-format-option.patch b/meta-python/recipes-devtools/python/python-jsonschema/0001-setup.cfg-add-non-GPL-format-option.patch
deleted file mode 100644
index afc38a30bf..0000000000
--- a/meta-python/recipes-devtools/python/python-jsonschema/0001-setup.cfg-add-non-GPL-format-option.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-From 8df0332475991884b8e1801d31f9c3e06d06bf9f Mon Sep 17 00:00:00 2001
-From: Nicola Lunghi <nick83ola@gmail.com>
-Date: Thu, 14 Nov 2019 18:58:56 +0000
-Subject: [PATCH] setup.cfg: add non GPL format option
-
-This is a rewrite of the following upstream commits:
-
- - 10f8a3e Add format validators as separate modules
- - af37707 non GPL format option
-
-removing all the non necessary bits (tox in particular)
-
-Original author: Nicolas Aimetti <naimetti@yahoo.com.ar>
-
-Upstream-status: Backported. [ to be removed for releases > 3.1.1 ]
----
- jsonschema/_format.py | 33 ++++++++++++++++++++++++++++-----
- setup.cfg | 6 ++++++
- 2 files changed, 34 insertions(+), 5 deletions(-)
-
-diff --git a/jsonschema/_format.py b/jsonschema/_format.py
-index aa04090..c967d98 100644
---- a/jsonschema/_format.py
-+++ b/jsonschema/_format.py
-@@ -248,7 +248,26 @@ else:
- try:
- import rfc3987
- except ImportError:
-- pass
-+ try:
-+ from rfc3986_validator import validate_rfc3986
-+ except ImportError:
-+ pass
-+ else:
-+ @_checks_drafts(name="uri",)
-+ def is_uri(instance):
-+ if not isinstance(instance, str_types):
-+ return True
-+ return validate_rfc3986(instance, rule="URI")
-+
-+ @_checks_drafts(
-+ draft6="uri-reference",
-+ draft7="uri-reference",
-+ raises=ValueError,
-+ )
-+ def is_uri_reference(instance):
-+ if not isinstance(instance, str_types):
-+ return True
-+ return validate_rfc3986(instance, rule="URI_reference")
- else:
- @_checks_drafts(draft7="iri", raises=ValueError)
- def is_iri(instance):
-@@ -280,15 +299,19 @@ else:
-
-
- try:
-- import strict_rfc3339
-+ from strict_rfc3339 import validate_rfc3339
- except ImportError:
-- pass
--else:
-+ try:
-+ from rfc3339_validator import validate_rfc3339
-+ except ImportError:
-+ validate_rfc3339 = None
-+
-+if validate_rfc3339:
- @_checks_drafts(name="date-time")
- def is_datetime(instance):
- if not isinstance(instance, str_types):
- return True
-- return strict_rfc3339.validate_rfc3339(instance)
-+ return validate_rfc3339(instance)
-
- @_checks_drafts(draft7="time")
- def is_time(instance):
-diff --git a/setup.cfg b/setup.cfg
-index 74bc4a7..878221c 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -40,6 +40,12 @@ format =
- rfc3987
- strict-rfc3339
- webcolors
-+format_nongpl =
-+ idna
-+ jsonpointer>1.13
-+ webcolors
-+ rfc3986-validator>0.1.0
-+ rfc3339-validator
-
- [options.entry_points]
- console_scripts =
---
-2.20.1
-
diff --git a/meta-python/recipes-devtools/python/python-jsonschema_3.1.1.bb b/meta-python/recipes-devtools/python/python-jsonschema_3.2.0.bb
index b677c646e7..b677c646e7 100644
--- a/meta-python/recipes-devtools/python/python-jsonschema_3.1.1.bb
+++ b/meta-python/recipes-devtools/python/python-jsonschema_3.2.0.bb
diff --git a/meta-python/recipes-devtools/python/python3-jsonschema_3.1.1.bb b/meta-python/recipes-devtools/python/python3-jsonschema_3.2.0.bb
index 9269907476..9269907476 100644
--- a/meta-python/recipes-devtools/python/python3-jsonschema_3.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-jsonschema_3.2.0.bb