aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2021-05-14 13:45:41 +0100
committerKhem Raj <raj.khem@gmail.com>2021-05-14 07:27:26 -0700
commit7fa165e0df482bc641b22789c28f9ea97ce858ee (patch)
tree7392ffebb57c5b510679b4326bd8c15704dd098f
parentc16459a2e62cc8b80c20d87b2fc5c4ac9038f69e (diff)
downloadmeta-openembedded-contrib-7fa165e0df482bc641b22789c28f9ea97ce858ee.tar.gz
nss: remove -march vs -mcpu workaround
NSS's build tries to be clever and passes for example -march=armv8-a+crypto explicitly, instead of relying on the person doing the compilation to set the right flags. This conflicts with our compiler flags which typically pass the ideal tune for the target, for example -mcpu=cortex-a55+crc+crypto. When this happens GCC warns that the flags conflict (which was promoted to an error, now fixed) and -march takes precedence over -mcpu. As there's a huge number of potential tune flags to remove to avoid the conflict, now that warnings are not fatal we can stop removing the flags and let GCC warn as the generated code is the same. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/nss/nss_3.64.bb4
1 files changed, 0 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/nss/nss_3.64.bb b/meta-oe/recipes-support/nss/nss_3.64.bb
index 119d4ad037..fce5a856ee 100644
--- a/meta-oe/recipes-support/nss/nss_3.64.bb
+++ b/meta-oe/recipes-support/nss/nss_3.64.bb
@@ -43,10 +43,6 @@ inherit siteinfo
TD = "${S}/tentative-dist"
TDS = "${S}/tentative-dist-staging"
-# cortex-a55 is ARMv8.2-a based but libatomic explicitly asks for -march=armv8.1-a
-# which caused -march conflicts in gcc
-TUNE_CCARGS_remove = "-mcpu=cortex-a55+crc -mcpu=cortex-a55 -mcpu=cortex-a55+crc+crypto"
-
TARGET_CC_ARCH += "${LDFLAGS}"
do_configure_prepend_libc-musl () {