aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Wiehler <stefan.wiehler@missinglinkelectronics.com>2021-05-12 15:08:40 +0200
committerKhem Raj <raj.khem@gmail.com>2021-05-12 07:11:41 -0700
commit6f47ea50610d760a8f84106f8ea7d582a96ddf02 (patch)
tree6f7398a791f924910db64ead0dc6308f2bffcad6
parent42e2ec56c7d96fd715fef90d76db393480ddaa66 (diff)
downloadmeta-openembedded-contrib-6f47ea50610d760a8f84106f8ea7d582a96ddf02.tar.gz
http-parser: add recipe
HTTP request/response parser for C. Signed-off-by: Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb b/meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb
new file mode 100644
index 0000000000..2d04ded343
--- /dev/null
+++ b/meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb
@@ -0,0 +1,30 @@
+SUMMARY = "HTTP request/response parser for C"
+DESCRIPTION = "This is a parser for HTTP messages written in C. It parses \
+ both requests and responses. The parser is designed to be used \
+ in performance HTTP applications. It does not make any \
+ syscalls nor allocations, it does not buffer data, it can be \
+ interrupted at anytime. Depending on your architecture, it \
+ only requires about 40 bytes of data per message stream (in a \
+ web server that is per connection)."
+AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>"
+HOMEPAGE = "https://github.com/nodejs/http-parser"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=9bfa835d048c194ab30487af8d7b3778"
+
+SRC_URI = "git://github.com/nodejs/http-parser.git"
+SRCREV = "2343fd6b5214b2ded2cdcf76de2bf60903bb90cd"
+
+S = "${WORKDIR}/git"
+
+do_configure[noexec] = "1"
+
+do_compile() {
+ oe_runmake library package
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D} PREFIX=${prefix}
+}
+
+BBCLASSEXTEND = "native nativesdk"