aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2021-01-17 20:00:41 -0800
committerKhem Raj <raj.khem@gmail.com>2021-01-18 14:35:52 -0800
commit6312f419ddc8100a57bb9f19fe0b826e656598e9 (patch)
treed81dd078b10934d5918cce80b956b6f1602c2b6d
parent2ed25eb4efecb23b47556e63cb9290945c3dea59 (diff)
downloadmeta-openembedded-contrib-6312f419ddc8100a57bb9f19fe0b826e656598e9.tar.gz
ipset: add recipe
This is needed for login-shield pkg in meta-security Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-filter/ipset/ipset_7.9.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-networking/recipes-filter/ipset/ipset_7.9.bb b/meta-networking/recipes-filter/ipset/ipset_7.9.bb
new file mode 100644
index 0000000000..95e48f0131
--- /dev/null
+++ b/meta-networking/recipes-filter/ipset/ipset_7.9.bb
@@ -0,0 +1,21 @@
+# Copyright (C) 2017 Aaron Brice <aaron.brice@datasoft.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Administration tool for IP sets"
+HOMEPAGE = "http://ipset.netfilter.org"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+SECTION = "base"
+
+DEPENDS = "libtool libmnl"
+
+SRC_URI = "http://ftp.netfilter.org/pub/ipset/${BP}.tar.bz2"
+SRC_URI[sha256sum] = "b75c13689eddf1d95b396840a69dc04fd7ae4112b10b70594bc0405df7b9b30a"
+
+inherit autotools pkgconfig module-base
+
+EXTRA_OECONF += "-with-kbuild=${KBUILD_OUTPUT} --with-ksource=${STAGING_KERNEL_DIR}"
+
+RRCOMMENDS_${PN} = "\
+ kernel-module-ip-set \
+"