aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-09 15:41:52 -0700
committerKhem Raj <raj.khem@gmail.com>2021-05-11 08:27:27 -0700
commit40622feb2e25a0e1ec72f6fda473d6523c21a7cc (patch)
tree478ef9fc680d79b7f9e8b86242aec7e1323e7100
parentaf43242a22861e9fc110d97cc4e06fed0be4325e (diff)
downloadmeta-openembedded-contrib-40622feb2e25a0e1ec72f6fda473d6523c21a7cc.tar.gz
libupnp: Do not use _np versions of mutex APIs
These APIs are deprecated/removed in future glibc 2.34+ Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andreas Müller <schnitzeltony@gmail.com>
-rw-r--r--meta-multimedia/recipes-connectivity/libupnp/libupnp/0001-ithread-Use-pthread_mutexattr_gettype-pthread_mutexa.patch42
-rw-r--r--meta-multimedia/recipes-connectivity/libupnp/libupnp_1.14.6.bb8
2 files changed, 47 insertions, 3 deletions
diff --git a/meta-multimedia/recipes-connectivity/libupnp/libupnp/0001-ithread-Use-pthread_mutexattr_gettype-pthread_mutexa.patch b/meta-multimedia/recipes-connectivity/libupnp/libupnp/0001-ithread-Use-pthread_mutexattr_gettype-pthread_mutexa.patch
new file mode 100644
index 0000000000..ee78196779
--- /dev/null
+++ b/meta-multimedia/recipes-connectivity/libupnp/libupnp/0001-ithread-Use-pthread_mutexattr_gettype-pthread_mutexa.patch
@@ -0,0 +1,42 @@
+From 343a3b724225d3c87af0b268da14d3acb7a5b9a1 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 9 May 2021 15:38:43 -0700
+Subject: [PATCH] ithread: Use
+ pthread_mutexattr_gettype/pthread_mutexattr_settype on linux
+
+_np variants are not recommended anymore, and glibc 2.34+ will have
+these removed
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ upnp/inc/ithread.h | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/upnp/inc/ithread.h b/upnp/inc/ithread.h
+index f6800ea9..1d0f9dba 100644
+--- a/upnp/inc/ithread.h
++++ b/upnp/inc/ithread.h
+@@ -304,7 +304,8 @@ static UPNP_INLINE int ithread_cleanup_thread(void)
+ * Returns EINVAL if the kind is not supported.
+ * See man page for pthread_mutexattr_setkind_np
+ *****************************************************************************/
+-#if defined(PTHREAD_MUTEX_RECURSIVE) || defined(__DragonFly__)
++#if defined(PTHREAD_MUTEX_RECURSIVE) || defined(__DragonFly__) \
++ || defined (__linux__)
+ #define ithread_mutexattr_setkind_np pthread_mutexattr_settype
+ #else
+ #define ithread_mutexattr_setkind_np pthread_mutexattr_setkind_np
+@@ -329,7 +330,8 @@ static UPNP_INLINE int ithread_cleanup_thread(void)
+ * Always returns 0.
+ * See man page for pthread_mutexattr_getkind_np
+ *****************************************************************************/
+-#if defined(PTHREAD_MUTEX_RECURSIVE) || defined(__DragonFly__)
++#if defined(PTHREAD_MUTEX_RECURSIVE) || defined(__DragonFly__) \
++ || defined (__linux__)
+ #define ithread_mutexattr_getkind_np pthread_mutexattr_gettype
+ #else
+ #define ithread_mutexattr_getkind_np pthread_mutexattr_getkind_np
+--
+2.31.1
+
diff --git a/meta-multimedia/recipes-connectivity/libupnp/libupnp_1.14.6.bb b/meta-multimedia/recipes-connectivity/libupnp/libupnp_1.14.6.bb
index ff6fb55dd3..81b42da412 100644
--- a/meta-multimedia/recipes-connectivity/libupnp/libupnp_1.14.6.bb
+++ b/meta-multimedia/recipes-connectivity/libupnp/libupnp_1.14.6.bb
@@ -9,7 +9,9 @@ LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=394a0f17b97f33426275571e15920434"
SRCREV = "cef2b23fb36baac091b0c7d41136b4c1d9549c6d"
-SRC_URI = "git://github.com/pupnp/pupnp.git;protocol=https;branch=branch-1.14.x"
+SRC_URI = "git://github.com/pupnp/pupnp.git;protocol=https;branch=branch-1.14.x \
+ file://0001-ithread-Use-pthread_mutexattr_gettype-pthread_mutexa.patch \
+ "
S="${WORKDIR}/git"
@@ -18,5 +20,5 @@ inherit autotools pkgconfig
EXTRA_OECONF += "--enable-reuseaddr"
# Enable LFS support ( for samples )
-CFLAGS += "-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
-CXXFLAGS += "-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+CFLAGS += "-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE"
+CXXFLAGS += "-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE"