aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2020-07-26 13:39:14 +0200
committerKhem Raj <raj.khem@gmail.com>2020-07-28 12:52:14 -0700
commit27c8dc4dc71ce744ad3721da5b66dc6227c5c954 (patch)
treeb6e2e1123820a9cb6c1ccc16e344cd113509cd90
parentcf0f1c64a475178532d4e41a3b1c926c2b8d3c2d (diff)
downloadmeta-openembedded-contrib-27c8dc4dc71ce744ad3721da5b66dc6227c5c954.tar.gz
crossguid: update to 0.2.2
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb (renamed from meta-multimedia/recipes-support/crossguid/crossguid.bb)13
1 files changed, 4 insertions, 9 deletions
diff --git a/meta-multimedia/recipes-support/crossguid/crossguid.bb b/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
index 228b8b6540..7441716635 100644
--- a/meta-multimedia/recipes-support/crossguid/crossguid.bb
+++ b/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
@@ -7,19 +7,14 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68"
DEPENDS += "util-linux"
-PV = "0.0+git${SRCPV}"
-
-SRCREV = "b56957ac453575e91ca1b63a80c0077c2b0d011a"
+SRCREV = "5b45cdd9a56ca9da35ee0f8845cb4e2603d245dc"
SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https"
S = "${WORKDIR}/git"
-do_compile() {
- ${CXX} -c guid.cpp -o guid.o ${CXXFLAGS} -std=c++11 -DGUID_LIBUUID
- ${AR} rvs libcrossguid.a guid.o
-}
+inherit cmake
do_install() {
- install -D -m 0644 ${B}/libcrossguid.a ${D}${libdir}/libcrossguid.a
- install -D -m 0644 ${S}/guid.h ${D}${includedir}/guid.h
+ install -D -m 0644 ${B}/libxg.a ${D}${libdir}/libxg.a
+ install -D -m 0644 ${S}/Guid.hpp ${D}${includedir}/Guid.hpp
}