aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2020-07-26 02:30:46 +0200
committerKhem Raj <raj.khem@gmail.com>2020-07-28 12:23:16 -0700
commit27c86f9404eb830c5e1c84bae7e2138cf1d8e7fc (patch)
tree4dbda632f58c5ae46820a019996930f730ac24d3
parent4bd3a42c94495572fec86da10c13dc388fdb3936 (diff)
downloadmeta-openembedded-contrib-27c86f9404eb830c5e1c84bae7e2138cf1d8e7fc.tar.gz
pmdk: update to 1.9
Removed patches: - 0001- was upstreamed - 0002- is now with with passing a config option License checksum changed due to modified copyright years. Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/pmdk/files/0001-examples-Initialize-child_idx.patch47
-rw-r--r--meta-oe/recipes-extended/pmdk/files/0002-Makefile-Don-t-install-the-docs.patch26
-rw-r--r--meta-oe/recipes-extended/pmdk/pmdk_1.9.bb (renamed from meta-oe/recipes-extended/pmdk/pmdk_1.8.bb)11
3 files changed, 4 insertions, 80 deletions
diff --git a/meta-oe/recipes-extended/pmdk/files/0001-examples-Initialize-child_idx.patch b/meta-oe/recipes-extended/pmdk/files/0001-examples-Initialize-child_idx.patch
deleted file mode 100644
index 8e2b3c7cbb..0000000000
--- a/meta-oe/recipes-extended/pmdk/files/0001-examples-Initialize-child_idx.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 721a48e5397bd4ab454482041e55671eae7b189f Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 11 May 2020 18:01:11 -0700
-Subject: [PATCH] examples: Initialize child_idx
-
-Assign UINT_MAX and assert it
-
-Fixes warning
-rtree_map.c:358:12: error: 'child_idx' may be used uninitialized
-in this function [-Werror=maybe-uninitialized]
-
-Upstream-Status: Submitted [https://github.com/pmem/pmdk/pull/4802]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/examples/libpmemobj/tree_map/rtree_map.c | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/examples/libpmemobj/tree_map/rtree_map.c b/src/examples/libpmemobj/tree_map/rtree_map.c
-index 995e22bb9..6b3ead65c 100644
---- a/src/examples/libpmemobj/tree_map/rtree_map.c
-+++ b/src/examples/libpmemobj/tree_map/rtree_map.c
-@@ -8,6 +8,7 @@
- #include <ex_common.h>
- #include <assert.h>
- #include <errno.h>
-+#include <limits.h>
- #include <stdlib.h>
- #include <stdbool.h>
-
-@@ -320,12 +321,13 @@ has_only_one_child(TOID(struct tree_map_node) node, unsigned *child_idx)
- static void
- remove_extra_node(TOID(struct tree_map_node) *node)
- {
-- unsigned child_idx;
-+ unsigned child_idx = UINT_MAX;
- TOID(struct tree_map_node) tmp, tmp_child;
-
- /* Our node has child with only one child. */
- tmp = *node;
- has_only_one_child(tmp, &child_idx);
-+ assert(child_idx != UINT_MAX);
- tmp_child = D_RO(tmp)->slots[child_idx];
-
- /*
---
-2.26.2
-
diff --git a/meta-oe/recipes-extended/pmdk/files/0002-Makefile-Don-t-install-the-docs.patch b/meta-oe/recipes-extended/pmdk/files/0002-Makefile-Don-t-install-the-docs.patch
deleted file mode 100644
index 82b96cf95e..0000000000
--- a/meta-oe/recipes-extended/pmdk/files/0002-Makefile-Don-t-install-the-docs.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 3863d8bd71d6a5638cf984f8d8f9cccac0c7f2a4 Mon Sep 17 00:00:00 2001
-From: Alistair Francis <alistair.francis@wdc.com>
-Date: Mon, 23 Jul 2018 11:31:17 -0700
-Subject: [PATCH] Makefile: Don't install the docs
-
-Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
-Upstream-Status: Inappropriate [disable feature]
----
- Makefile | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index 47a447f12..7c0f9848f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -148,7 +148,6 @@ rpm dpkg: pkg-clean
-
- install uninstall:
- $(MAKE) -C src $@
-- $(MAKE) -C doc $@
-
- .PHONY: all clean clobber test check cstyle check-license install uninstall\
- source rpm dpkg pkg-clean pcheck check-remote format doc require-rpmem\
---
-2.14.4
-
diff --git a/meta-oe/recipes-extended/pmdk/pmdk_1.8.bb b/meta-oe/recipes-extended/pmdk/pmdk_1.9.bb
index fe7b760e22..8bb89f418c 100644
--- a/meta-oe/recipes-extended/pmdk/pmdk_1.8.bb
+++ b/meta-oe/recipes-extended/pmdk/pmdk_1.9.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Persistent Memory Development Kit"
HOMEPAGE = "http://pmem.io"
SECTION = "libs"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=1b8430f251523f1bff0c9fb95da7e0ca"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b44ee63f162f9cdb18fff1224877aafd"
DEPENDS = "ndctl"
# Required to have the fts.h header for musl
@@ -11,12 +11,9 @@ DEPENDS_append_libc-musl = " fts"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/pmem/pmdk.git \
- file://0001-examples-Initialize-child_idx.patch \
- file://0002-Makefile-Don-t-install-the-docs.patch \
- "
+SRC_URI = "git://github.com/pmem/pmdk.git"
-SRCREV = "0245d75eaf0f6106c86a7926a45fdf2149e37eaa"
+SRCREV = "1926ffb8f3f5f0617b3b3ed32029d437c272f187"
inherit autotools-brokensep pkgconfig
@@ -25,7 +22,7 @@ inherit autotools-brokensep pkgconfig
# | If you meant to cross compile, use `--host'.
#
# Also fix #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp]
-EXTRA_OEMAKE = "BUILD_EXAMPLES='n' HOST_SYS='${HOST_SYS}' EXTRA_CFLAGS='${SELECTED_OPTIMIZATION}' LIB_PREFIX=${baselib}"
+EXTRA_OEMAKE = "BUILD_EXAMPLES='n' DOC='n' HOST_SYS='${HOST_SYS}' EXTRA_CFLAGS='${SELECTED_OPTIMIZATION}' LIB_PREFIX=${baselib}"
# Fix the missing fts libs when using musl
EXTRA_OEMAKE_append_libc-musl = " EXTRA_LIBS='-lfts'"