aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-10 17:07:20 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-11 08:25:56 -0700
commit178ef37ed7dd2c7febed859f78c27bbf51040cef (patch)
tree97714394a81dc7e9ea8e2915fb4ed7f2dc760919
parentdfd68d4dbe453a0cb83a20cebb8e73d2f216ca62 (diff)
downloadmeta-openembedded-contrib-178ef37ed7dd2c7febed859f78c27bbf51040cef.tar.gz
python3-websockets: Upgrade 8.1 -> 9.0.1
Upgrade to release 9.0.1: - Fixed issues with the packaging of the 9.0 release. - :class:`~datastructures.Headers` and :exc:`~datastructures.MultipleValuesError` were moved from websockets.http to :mod:`websockets.datastructures`. If you're using them, you should adjust the import path. - The client, server, protocol, and auth modules were moved from the websockets package to websockets.legacy sub-package, as part of an upcoming refactoring. Despite the name, they're still fully supported. The refactoring should be a transparent upgrade for most uses when it's available. The legacy implementation will be preserved according to the backwards-compatibility policy. - The framing, handshake, headers, http, and uri modules in the websockets package are deprecated. These modules provided low-level APIs for reuse by other WebSocket implementations, but that never happened. Keeping these APIs public makes it more difficult to improve websockets for no actual benefit. - Added compatibility with Python 3.9. - Added support for IRIs in addition to URIs. - Added close codes 1012, 1013, and 1014. - Raised an error when passing a :class:`dict` to :meth:`~legacy.protocol.WebSocketCommonProtocol.send`. - Fixed sending fragmented, compressed messages. - Fixed Host header sent when connecting to an IPv6 address. - Fixed creating a client or a server with an existing Unix socket. - Aligned maximum cookie size with popular web browsers. - Ensured cancellation always propagates, even on Python versions where :exc:`~asyncio.CancelledError` inherits :exc:`Exception`. - Improved error reporting. License-Update: Update years Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-websockets_9.0.1.bb (renamed from meta-python/recipes-devtools/python/python3-websockets_8.1.bb)5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-websockets_8.1.bb b/meta-python/recipes-devtools/python/python3-websockets_9.0.1.bb
index b09e978af7..58f4f10ff7 100644
--- a/meta-python/recipes-devtools/python/python3-websockets_8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-websockets_9.0.1.bb
@@ -2,12 +2,11 @@ SUMMARY = "An implementation of the WebSocket Protocol (RFC 6455)"
HOMEPAGE = "https://github.com/aaugustin/websockets"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ad5c6d36b3d0098b2f33a5ab69a9e750"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=78c2cc91e172ca96d6f8e4a76c739ec6"
inherit pypi setuptools3
-SRC_URI[md5sum] = "f12d7f31fe8d0b3e65c12f845bcd0ad8"
-SRC_URI[sha256sum] = "5c65d2da8c6bce0fca2528f69f44b2f977e06954c8512a952222cea50dad430f"
+SRC_URI[sha256sum] = "2ab64e9fd18e57a66b63a8774e337d81d6366412bef65c7d71f87ad5c4faeed5"
BBCLASSEXTEND = "native nativesdk"