aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-06-22 16:16:12 -0400
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:41 -0700
commita7de6127847aef95f32f52c2bc3718d20d8f4fec (patch)
treed87189488c12138f9d8c3b0d4b613f8b650c2cc6
parent1012067b37cb38c3d83c7e0ee202a2561a0f044a (diff)
downloadmeta-openembedded-contrib-a7de6127847aef95f32f52c2bc3718d20d8f4fec.tar.gz
evince: fix build errors with gcc-6
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 979760c69b41a4ecb67776278a1c248111ad5515) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/evince/evince/0002-fix-gcc6-errors.patch39
-rw-r--r--meta-gnome/recipes-gnome/evince/evince_3.18.2.bb4
2 files changed, 42 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/evince/evince/0002-fix-gcc6-errors.patch b/meta-gnome/recipes-gnome/evince/evince/0002-fix-gcc6-errors.patch
new file mode 100644
index 0000000000..b8e30f7d92
--- /dev/null
+++ b/meta-gnome/recipes-gnome/evince/evince/0002-fix-gcc6-errors.patch
@@ -0,0 +1,39 @@
+--- evince-3.18.2/backend/comics/comics-document.c.orig 2016-06-22 20:08:01.789805750 +0000
++++ evince-3.18.2/backend/comics/comics-document.c 2016-06-22 20:07:00.817804688 +0000
+@@ -241,6 +241,8 @@
+ /* This function shows how to use the choosen command for decompressing a
+ * comic book file. It modifies fields of the ComicsDocument struct with
+ * this information */
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wformat-nonliteral"
+ static gboolean
+ comics_generate_command_lines (ComicsDocument *comics_document,
+ GError **error)
+@@ -296,6 +298,7 @@
+ }
+
+ }
++#pragma GCC diagnostic pop
+
+ /* This function chooses an external command for decompressing a comic
+ * book based on its mime tipe. */
+--- evince-3.18.2/libdocument/ev-document-misc.c.orig 2016-06-22 20:01:49.205799262 +0000
++++ evince-3.18.2/libdocument/ev-document-misc.c 2016-06-22 20:02:27.233799924 +0000
+@@ -519,7 +519,8 @@
+
+ return (dp / di);
+ }
+-
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wformat-y2k"
+ /* Returns a locale specific date and time representation */
+ gchar *
+ ev_document_misc_format_date (GTime utime)
+@@ -542,6 +543,7 @@
+
+ return g_locale_to_utf8 (s, -1, NULL, NULL, NULL);
+ }
++#pragma GCC diagnostic pop
+
+ void
+ ev_document_misc_get_pointer_position (GtkWidget *widget,
diff --git a/meta-gnome/recipes-gnome/evince/evince_3.18.2.bb b/meta-gnome/recipes-gnome/evince/evince_3.18.2.bb
index fe63093adf..5e6b30f71d 100644
--- a/meta-gnome/recipes-gnome/evince/evince_3.18.2.bb
+++ b/meta-gnome/recipes-gnome/evince/evince_3.18.2.bb
@@ -10,7 +10,9 @@ inherit gnome pkgconfig gtk-icon-cache gsettings gobject-introspection
SRC_URI[archive.md5sum] = "c39af6b8b1c44d4393ef8ac9dab99c0b"
SRC_URI[archive.sha256sum] = "42ad6c7354d881a9ecab136ea84ff867acb942605bcfac48b6c12e1c2d8ecb17"
-SRC_URI += "file://0001-help-remove-YELP-macro.patch"
+SRC_URI += "file://0001-help-remove-YELP-macro.patch \
+ file://0002-fix-gcc6-errors.patch \
+"
EXTRA_OECONF = " --enable-thumbnailer \
"