aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHoward Cochran <Howard_Cochran@jabil.com>2022-09-15 14:09:42 -0400
committerArmin Kuster <akuster808@gmail.com>2022-11-01 08:49:34 -0400
commiteeeec7d911875a3dd85f0c0007a9bdf21b94a2ef (patch)
treea67b3ea3fd4e56d904ad347288a20c67bc441ec9
parent744a4b6eda88b9a9ca1cf0df6e18be384d9054e3 (diff)
downloadmeta-openembedded-contrib-eeeec7d911875a3dd85f0c0007a9bdf21b94a2ef.tar.gz
ufw: Fix "could not find required binary 'iptables'"
Switch from using DISTUTILS_*_ARGS to SETUPTOOLS_*_ARGS to correspond with the earlier change to use setuptools3_legacy instead of distutils3. Without this change, you will get the following error if your build host does not have iptables installed: Fixes: ERROR: ufw-0.36.1-r0 do_compile: 'python3 setup.py build ' execution failed. Log data follows: | DEBUG: Executing shell function do_compile | ERROR: could not find required binary 'iptables' | ERROR: 'python3 setup.py build ' execution failed. | WARNING: exit code 1 from a shell command. ERROR: Task ([snip]/meta-openembedded/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb:do_compile) failed with exit code '1' Also, although the build will not fail on a host that has iptables, it could cause a problem if it is installed at a different path than where OpenEmbedded's iptables will be installed on the target. Fixes: 3e2ed1dcc088 ("ufw: port to setuptools, use setuptools_legacy") Signed-off-by: Howard Cochran <howard_cochran@jabil.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb b/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
index b6a768e08a..c479eefba0 100644
--- a/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
+++ b/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
@@ -70,5 +70,5 @@ FILES:${PN} += " \
REQUIRED_DISTRO_FEATURES = "ipv6"
-DISTUTILS_BUILD_ARGS:append = " --iptables-dir /usr/sbin"
-DISTUTILS_INSTALL_ARGS:append = " --iptables-dir /usr/sbin"
+SETUPTOOLS_BUILD_ARGS:append = " --iptables-dir /usr/sbin"
+SETUPTOOLS_INSTALL_ARGS:append = " --iptables-dir /usr/sbin"