aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2021-12-03 21:39:14 +0100
committerArmin Kuster <akuster808@gmail.com>2021-12-18 11:23:41 -0800
commit37b9a7a114e872c07bfe9881bc27c7ed87a394fb (patch)
tree81bef4b765395cfca69a9c252a03ad56684725ed
parenta12eff7e3f6aa1d4150b0724d4b7939622aa598f (diff)
downloadmeta-openembedded-contrib-37b9a7a114e872c07bfe9881bc27c7ed87a394fb.tar.gz
gattlib: Explicitly disable Python support
Under some configuration, CMake may pick up the existence of python from the native recipe sysroot and use that when linking for target, resulting in the following error: ld: .../recipe-sysroot-native/usr/lib/libpython3.10.so: error adding symbols: file in wrong format Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/gattlib/gattlib_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb b/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
index ecff79be45..3fe4c9404c 100644
--- a/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
+++ b/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
@@ -23,6 +23,7 @@ PACKAGECONFIG[examples] = "-DGATTLIB_BUILD_EXAMPLES=ON,-DGATTLIB_BUILD_EXAMPLES=
# Set this to force use of DBus API if Bluez version is older than 5.42
PACKAGECONFIG[force-dbus] = "-DGATTLIB_FORCE_DBUS=TRUE,-DGATTLIB_FORCE_DBUS=FALSE"
+EXTRA_OECMAKE += "-DGATTLIB_PYTHON_INTERFACE=OFF"
EXTRA_OECMAKE += "-DGATTLIB_BUILD_DOCS=OFF"
inherit pkgconfig cmake