aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Battersby <tonyb@cybernetics.com>2021-07-27 09:37:34 -0400
committerArmin Kuster <akuster808@gmail.com>2021-08-01 09:27:00 -0700
commiteee9348f79b0f70fbd57db28b5def4db85d564c6 (patch)
tree932d3c8a0ca5f2a0b44b12808a6c7249a107b787
parent69dcf5bac8adfd55f1a40cff1e989ed8806607cb (diff)
downloadmeta-openembedded-contrib-eee9348f79b0f70fbd57db28b5def4db85d564c6.tar.gz
net-snmp: fix QA Issue after LDFLAGS change
Adding -f*-prefix-map to LDFLAGS caused the following issue: QA Issue: netsnmp-agent.pc failed sanity test (tmpdir) Fix by filtering out -f*-prefix-map from *.pc files. [YOCTO #14481] Signed-off-by: Tony Battersby <tonyb@cybernetics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 5e042ac2079bffa3ae3d9839a50bf6a3d3f1930a) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb
index 7c3d5babd8..0150d3e38a 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb
@@ -131,6 +131,11 @@ do_install_append() {
-e 's@[^ ]*PKG_CONFIG_LIBDIR=[^ "]*@@g' \
-i ${D}${bindir}/net-snmp-config
+ sed -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
+ -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
+ -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
+ -i ${D}${libdir}/pkgconfig/netsnmp*.pc
+
# ${STAGING_DIR_HOST} is empty for native builds, and the sed command below
# will result in errors if run for native.
if [ "${STAGING_DIR_HOST}" ]; then