aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Fan Yu <yifan.yu@windriver.com>2021-04-16 19:36:54 -0400
committerArmin Kuster <akuster808@gmail.com>2021-04-18 13:49:13 -0700
commita56b4e9c48fdb04b8dcad13dd45583c9a1c1296c (patch)
tree879f138c0aae2c875fb16ebf6689510a657ffad1
parentf5d3ba9fec8e4d5a261f2ce470a785c50e4615ca (diff)
downloadmeta-openembedded-contrib-a56b4e9c48fdb04b8dcad13dd45583c9a1c1296c.tar.gz
syslog-ng: Drop an obsolete patch to add --enable-libnet
libnet is a dependency to --enable-spoof-source. The correct flag to enable/disable in ./configure is --enable-spoof-source. Adjust PACKAGECONFIG accordingly. Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit c126dcd1f91236d7effdb64df7fd9a3e2029543d) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/0004-configure.ac-add-libnet-enable-option.patch77
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc2
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng_3.31.2.bb1
3 files changed, 1 insertions, 79 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/files/0004-configure.ac-add-libnet-enable-option.patch b/meta-oe/recipes-support/syslog-ng/files/0004-configure.ac-add-libnet-enable-option.patch
deleted file mode 100644
index c9eec65e87..0000000000
--- a/meta-oe/recipes-support/syslog-ng/files/0004-configure.ac-add-libnet-enable-option.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From 57b509adfb7c62bbf55ea1709aac3383cab660fa Mon Sep 17 00:00:00 2001
-From: Ming Liu <ming.liu@windriver.com>
-Date: Thu, 17 Jul 2014 05:37:08 -0400
-Subject: [PATCH] configure.ac: add libnet enable option
-
-This would avoid a implicit auto-detecting result
-
-Signed-off-by: Ming Liu <ming.liu@windriver.com>
-Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
-
-Update for 3.24.1.
-Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
-
-Set it to default yes
-
-Upstream-Status: Submitted [https://github.com/syslog-ng/syslog-ng/pull/3650]
-
-Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com>
----
- configure.ac | 35 ++++++++++++++++++++---------------
- 1 file changed, 20 insertions(+), 15 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 7aad75f..d575cba 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -144,6 +144,9 @@ AC_CONFIG_HEADERS(config.h)
- dnl ***************************************************************************
- dnl Arguments
-
-+AC_ARG_ENABLE(libnet,
-+ [ --enable-libnet Enable libnet support (default: yes)],, enable_libnet="yes")
-+
- AC_ARG_WITH(libnet,
- [ --with-libnet=path use path to libnet-config script],
- ,
-@@ -1073,23 +1076,25 @@ dnl ***************************************************************************
- dnl libnet headers/libraries
- dnl ***************************************************************************
- AC_MSG_CHECKING(for LIBNET)
--if test "x$with_libnet" = "x"; then
-- LIBNET_CONFIG="`which libnet-config`"
--else
-- LIBNET_CONFIG="$with_libnet/libnet-config"
--fi
-+if test "x$enable_libnet" = xyes; then
-+ if test "x$with_libnet" = "x"; then
-+ LIBNET_CONFIG="`which libnet-config`"
-+ else
-+ LIBNET_CONFIG="$with_libnet/libnet-config"
-+ fi
-
--if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
-- LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`"
-- LIBNET_LIBS="`$LIBNET_CONFIG --libs`"
-- AC_MSG_RESULT(yes)
--dnl libnet-config does not provide the _DEFAULT_SOURCE define, that can cause warning during build
--dnl as upstream libnet-config does uses _DEFAULT_SOURCE this is just a fix till
-- LIBNET_CFLAGS="$LIBNET_CFLAGS -D_DEFAULT_SOURCE"
-+ if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
-+ LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`"
-+ LIBNET_LIBS="`$LIBNET_CONFIG --libs`"
-+ AC_MSG_RESULT(yes)
-+ dnl libnet-config does not provide the _DEFAULT_SOURCE define, that can cause warning during build
-+ dnl as upstream libnet-config does uses _DEFAULT_SOURCE this is just a fix till
-+ LIBNET_CFLAGS="$LIBNET_CFLAGS -D_DEFAULT_SOURCE"
-
--else
-- LIBNET_LIBS=
-- AC_MSG_RESULT(no)
-+ else
-+ LIBNET_LIBS=
-+ AC_MSG_RESULT(no)
-+ fi
- fi
-
-
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index e48e5d5e2f..80c5099731 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -50,7 +50,7 @@ PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,,"
PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_unitdir}/system/,--disable-systemd --without-systemdsystemunitdir,systemd,"
PACKAGECONFIG[linux-caps] = "--enable-linux-caps,--disable-linux-caps,libcap,"
PACKAGECONFIG[dbi] = "--enable-sql,--disable-sql,libdbi,"
-PACKAGECONFIG[libnet] = "--enable-libnet --with-libnet=${STAGING_BINDIR_CROSS},--disable-libnet,libnet,"
+PACKAGECONFIG[spoof-source] = "--enable-spoof-source --with-libnet=${STAGING_BINDIR_CROSS},--disable-spoof-source,libnet,"
PACKAGECONFIG[http] = "--enable-http,--disable-http,curl,"
PACKAGECONFIG[smtp] = "--enable-smtp --with-libesmtp=${STAGING_LIBDIR},--disable-smtp,libesmtp,"
PACKAGECONFIG[json] = "--enable-json,--disable-json,json-c,"
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.31.2.bb b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.31.2.bb
index cbd218c95b..5d2b7f77ea 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.31.2.bb
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.31.2.bb
@@ -10,7 +10,6 @@ SRC_URI += "https://github.com/balabit/syslog-ng/releases/download/${BP}/${BP}.t
file://syslog-ng-tmp.conf \
file://syslog-ng.service-the-syslog-ng-service.patch \
file://0002-scl-fix-wrong-ownership-during-installation.patch \
- file://0004-configure.ac-add-libnet-enable-option.patch \
file://0005-.py-s-python-python3-exclude-tests.patch \
"
SRC_URI[md5sum] = "69ef4dc5628d5e603e9e4a1b937592f8"